Opened 6 years ago

Closed 5 years ago

#11023 closed defect (worksforme)

Unable to run Tor Browser

Reported by: Chomp Owned by: brade
Priority: Medium Milestone:
Component: Applications/Tor Launcher Version:
Severity: Keywords:
Cc: mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Downloaded new version from "https://www.torproject.org/download/download-easy.html.en"
clicked on "torbrowser-install-3.5.2.1_en-US.exe". Appears to be a self-extracting file.
It created a new folder "Tor Browser: with folder with 4 folders and
"Start Tor Browser".
I get a message "Could not connect to TOR Control Port".
I closed the message and clicked on "Start Tor Browser" again.
Got message:Firefox is already running, but is not responding.
To open a new window, you must first close the existing Firefox
process, or restart your system.
Cancelled Firefox through task manager. Clicked on "Start Tor Browser"
and it appears nothing happens.
Systems
64 bit system Windows 7
8 gig Ram
Herd of disk space.
Do I need to install a separate copy of FireFox?

Child Tickets

Change History (14)

comment:1 Changed 6 years ago by cypherpunks

Component: - Select a componentTor bundles/installation
Owner: set to erinn
Summary: Unable to Rune Tor BrowserUnable to run Tor Browser
Version: Tor: unspecified

comment:2 Changed 6 years ago by cypherpunks

I get a message "Could not connect to TOR Control Port".

Check your firewall settings, it should to allow localhost connections Tor Browser and Tor.

I closed the message and clicked on "Start Tor Browser" again.

What about window with title "Tor Network Settings"? Or window with title "Tor Status"?

comment:3 Changed 6 years ago by Chomp

I closed firewall
Did a cold boot
Clicked on Start Tor Browser
Nothing came up. No Tor Network Settings or Tor Status
Task manager shows FireFox.exe *32 - TorBrowser running. No window for FireFox
Nothing in task manager for Tor
Opened Tor folder
Clicked on Tor exe
Got window “Tor Network Settings” Message in window “waiting for Tor to start”. No options available
Second window “Tor Launcher” Message “Could not connect to Tor control port”
Tor exe * showing in task manager.
Ended process for Tor.exe and FireFox.
Opened Tor Browser folder and clicked on FireFox. FireFox did not launch.
FireFox running in task Manager
Opened Tor Browser clicked on Tor.exe. Nothing Launched.
Tor.exe running in task manager. There are 2 Tor.exe’s showing in task manager
Ended FireFox.exe process
Unable to end either Tor.exe process

comment:4 Changed 6 years ago by Chomp

I downloaded the Tor bundle again and tried to run. Nothing came up.
I opened the Tor Browser file folder and clicked on Firefox.exe. Nothing loaded.
Checked task manager, FireFox.exe running.

comment:5 Changed 6 years ago by cypherpunks

Is it your first using of TBB, or did you use previous versions successfully before?
What AV and Firewall used?

“Could not connect to Tor control port”

It's primary sign of something wrong with configuration for your environment. You need to find reason of it and fix. All another malfunctions related to this one.

I opened the Tor Browser file folder and clicked on Firefox.exe.

No need to start firefox.exe. Only proper way to start Tor browser is "Start Tor Browser.exe"

Last edited 6 years ago by cypherpunks (previous) (diff)

comment:6 Changed 6 years ago by Chomp

This is the first time using TBB.
I did download FireFox by its self and it loaded with any problems.
I will try to see if there configuration settings I can adjust.

comment:7 Changed 6 years ago by Chomp

When installing Tor Bundle I have notices that I do not get anything that looks like what is displayed on the Installing on Windows Page (https://www.torproject.org/docs/tor-doc-windows.html.en). The one thing I am not seeing is Vidalia. It is not loading and does not appear in Task Manager.
I went checked all the files that were downloaded with the Tor Bundle and did not find Vidalia anywhere. In the bundle there are 4 folders and the Start Tor Browser.exe. The for files are Browser, Data, Docs and, Tor. I was unable to locate any reference to Vidalia.
I downloaded Vidalia by its self and when I tried to launch, it hung. I will keep looking

comment:8 Changed 6 years ago by cypherpunks

The one thing I am not seeing is Vidalia. It is not loading and does not appear in Task Manager.

New Torbrowser (since TBB3.x) do not using Vidalia to control Tor anymore. It using extension TorLauncher that allows browser to launch Tor. Documentation from site is outdated partially. Look at https://www.torproject.org/docs/faq.html.en#TBB3.x

I downloaded Vidalia by its self and when I tried to launch, it hung. I will keep looking

What antivirus do you using? KAV, McAfee, AVG, Webroot?
What firewall do you using? Outpost, KIS, Comodo?

comment:9 Changed 6 years ago by cypherpunks

You can to try get support yet. Look at https://www.torproject.org/docs/faq.html.en#SupportMail

comment:10 Changed 6 years ago by badon

Priority: normalcritical

I was getting this error too. Now, in 3.6.1 it's different error messages, but the end result is the same, which leads me to believe this is indeed a bug in TBB. First, Firefox.exe starts up, and the process claims it is "TorBrowser" when viewed in Process Hacker. Then, tor.exe starts up, and it sits idle for a long time. Then the first error message pops up that says:

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: jar:file:///C:/path/to/Tor%20Browser%203.6.1/Data/Browser/profile.default/extensions/tor-launcher@torproject.org.xpi!/components/tl-protocol.js:613

I didn't keep good notes about what happens after that, but this info might be sufficient to determine how to fix the bug. If more info is needed, I can do further testing. I do remember that it offered to copy log info about the problem to clipboard, but nothing was actually copied (the clipboard was blank).

Note that in my use case, I have several other instances of Tor running (TorChat, etc). I strongly suspect that is a contributing factor, but I have manually verified there are no port usage conflicts. 9050 is the default port in plain Tor, and TBB uses 9150, if I remember correctly.

I changed the priority of this bug from "normal" to "critical" because it totally prevents TBB from functioning, and it doesn't provide any error messages that might be useful if it turns out to be a conflict with already running software.

Last edited 6 years ago by badon (previous) (diff)

comment:11 Changed 6 years ago by arma

Component: Tor bundles/installationTor Launcher
Owner: changed from erinn to brade
Priority: criticalnormal

Moving to the Tor launcher component, because my rudimentary pattern-matching skills found the substring tor-launcher.

Badon, can you shut down all your other things, and try it, and confirm that it works in that case? And if so, bring them back one at a time to get some more details on which one is causing your problem?

comment:12 Changed 6 years ago by badon

I just tested it with other instances of Tor and Firefox shut down, and it still failed to start up. I tried it on another machine with a similar configuration, and it started up immediately as it should, WITHOUT me needing to shut down anything. So, I'm stumped. Are there logs somewhere that might indicate what's going on, other than the JavaScript error message I pasted in comment 10?

comment:13 Changed 6 years ago by badon

I have made some progress in studying this bug. I copied my portable Tor Browser Bundle to another drive, and it worked! That was very unexpected, but I got firewall popups asking me to allow TBB components to talk to each other, in addition to talking to the internet. My immediate suspicion was that this bug was invalid, because it is likely to be a firewall problem. So, I investigated firewall logs and permissions and found nothing at all - I expected to find that my original copy had been blocked by the firewall, but it wasn't. So, I tried my original copy again, expecting it to not work exactly like it was previously, but it DID work.

So, in short, I've got a new avenue of research, but I still haven't accomplished much. I'm not convinced the firewall is responsible or not responsible, but if I can get the problem to recur, I'll modify the torrc file to get some logs out of Tor to see what it is doing. I think the problem happens when TBB components can't communicate with each other, so my hypothesis is that Tor does successfully connect to the Tor network. I'll test that hypothesis at my next opportunity, if it recurs.

If it doesn't recur, then I guess we'll have to mark this bug as "worksforme". Spontaneously resolving bugs are the best kind!

comment:14 Changed 5 years ago by mcs

Cc: mcs added
Resolution: worksforme
Status: newclosed

Resolving as "worksforme". Please reopen this bug if the problem recurs.

Note: See TracTickets for help on using tickets.