Opened 10 years ago

Closed 8 years ago

Last modified 7 years ago

#1104 closed defect (duplicate)

We should have an option that disables connections to bridge auth and fallback

Reported by: Sebastian Owned by:
Priority: Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version: 0.2.1.19
Severity: Keywords: tor-bridge
Cc: Sebastian, nickm Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by nickm)

] I meant UpdateBridgesFromAuthority 0
] Or does that not prevent connections to the Authority?
] If it doesn't, I think we should have some config option that means

"never talk to the bridge authority". Else it's easier to spot that
someone is trying to use Tor

arma] right. we've never really solved that part of the problem. i

figured i'd do it once somebody blocks it.

arma] whether tor decides to go to the bridge authority directly

depends on a couple of things.

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Change History (7)

comment:1 Changed 9 years ago by nickm

Under what circumstances will a Tor decide to connect to a bridge authority directly for other stuff? It might be worthwhile to fix this, but I don't see enough info here to tell if it wants to be for 0.2.2.x or not.

comment:2 Changed 9 years ago by nickm

Description: modified (diff)
Milestone: Tor: unspecified

comment:3 Changed 8 years ago by arma

Looking at the discussion, I think what I meant here wrt "we never really solved that part of the problem" was going to the bridge authority only if you can reach it over Tor, and never otherwise.

The UpdateBridgesFromAuthority config option does the safe thing, which is that if you set it to 0 you will ignore the bridge authority in all ways.

In the future we'll want to get smarter; but we'll need to resolve #1938 first (or in parallel).

In fact, I'm tempted to close this trac entry since #1938 and #1852 are more comprehensive.

comment:4 Changed 8 years ago by arma

Component: Tor ClientTor Bridge

comment:5 Changed 8 years ago by arma

Resolution: Noneduplicate
Status: newclosed

Duplicate of #1938

comment:6 Changed 7 years ago by nickm

Keywords: tor-bridge added

comment:7 Changed 7 years ago by nickm

Component: Tor BridgeTor
Note: See TracTickets for help on using tickets.