Opened 5 years ago

Closed 5 years ago

#11058 closed defect (duplicate)

check.tpo occasionally points to wrong relay on atlas.tpo

Reported by: infinity0 Owned by: arlolra
Priority: Medium Milestone:
Component: Applications/Tor Check Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm not sure exactly how to reproduce this, but arma and I both got this separately within about 20 minutes of each other.

When you visit check.tpo, it says "Your IP address appears to be X". And separately, "For more information about this relay, see: [Atlas]", but when you click on this link, it shows a relay that is not X.

me: check said 109.163.234.8, but atlas link was to https://atlas.torproject.org/#details/6018E567218564B0BE2F2EA3C113C886B0BB7957
arma: check said 96.47.226.20, but atlas link was to https://atlas.torproject.org/#details/DCD6AD4ABB48BF5FE8C52089DC0E768039A3B8E1

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by arlolra

Resolution: duplicate
Status: newclosed

Thanks for reporting. This is a duplicate of #10499.

What's happening is that TorDNSEL is conflating IPs with the wrong nodes,
and check needs to remember IPs it has seen from relays in the past.

From the data at metrics.tpo, we see many incorrectly assigned exit addresses.

./11/2014-02-11-02-02-10:ExitNode 6018E567218564B0BE2F2EA3C113C886B0BB7957
./11/2014-02-11-02-02-10-Published 2014-02-10 22:09:27
./11/2014-02-11-02-02-10-LastStatus 2014-02-10 23:02:10
./11/2014-02-11-02-02-10-ExitAddress 185.2.138.125 2014-02-10 01:06:38
./11/2014-02-11-02-02-10-ExitAddress 109.163.234.8 2014-02-10 01:06:38
./11/2014-02-11-02-02-10-ExitAddress 88.191.103.153 2014-02-10 08:11:32
./11/2014-02-11-02-02-10-ExitAddress 193.107.85.59 2014-02-10 08:11:37
./11/2014-02-11-02-02-10-ExitAddress 193.111.141.30 2014-02-10 08:11:37
./11/2014-02-11-02-02-10-ExitAddress 78.108.63.44 2014-02-10 08:11:38
./11/2014-02-11-02-02-10-ExitAddress 81.89.96.88 2014-02-10 21:11:24
./11/2014-02-11-02-02-10-ExitAddress 185.17.93.142 2014-02-10 21:11:25
./11/2014-02-11-02-02-10-ExitAddress 82.146.48.179 2014-02-10 23:09:03
./11/2014-02-11-02-02-10-ExitAddress 50.7.210.218 2014-02-10 23:09:03
./11/2014-02-11-02-02-10-ExitAddress 173.242.121.199 2014-02-10 23:09:03
./11/2014-02-11-02-02-10-ExitAddress 223.223.175.253 2014-02-10 23:09:04
./20/2014-02-20-06-02-02:ExitNode DCD6AD4ABB48BF5FE8C52089DC0E768039A3B8E1
./20/2014-02-20-06-02-02-Published 2014-02-19 09:20:17
./20/2014-02-20-06-02-02-LastStatus 2014-02-20 04:02:43
./20/2014-02-20-06-02-02-ExitAddress 96.47.226.20 2014-02-19 05:18:56
./20/2014-02-20-06-02-02-ExitAddress 178.254.39.32 2014-02-19 05:20:12
./20/2014-02-20-06-02-02-ExitAddress 93.174.90.30 2014-02-19 05:20:18
./20/2014-02-20-06-02-02-ExitAddress 77.247.181.165 2014-02-19 13:18:24
./20/2014-02-20-06-02-02-ExitAddress 109.163.234.9 2014-02-19 13:18:35

Karsten suggested a fix of linking to atlas' search for the IP, rather than directly to a fingerprint. This has the bonus of solving the case where multiple nodes are hosted on the same IP.

Note: See TracTickets for help on using tickets.