Opened 10 years ago

Closed 9 years ago

#1106 closed enhancement (worksforme)

More information after Settings Test fail

Reported by: phip Owned by:
Priority: Low Milestone:
Component: Applications/Torbutton Version: 1.2.2
Severity: Keywords:
Cc: phip Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by mikeperry)

When I click "test settings" in the torbutton preferences window, it tells me:
"Tor proxy test FAILED! Check your proxy and Privoxy settings."
...This doesn't help me figure anything out.
I have tor running through vidalia, and its log says:
"[Notice] Tor has successfully opened a circuit. Looks like client functionality is working."
I have privoxy running.
Netstat shows listening ports open on 8118, 9050, and 9051.

I wish the test failure message gave information about what failed, so I'd know where to look.

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Change History (5)

comment:1 Changed 10 years ago by phip

After posting this I read the test code and realized it just queries https://check.torproject.org/?TorButton=true, so while I can't figure out why the check is failing, I guess torbutton isn't at fault. Close is fine.

comment:2 Changed 10 years ago by downie

https://check.torproject.org/?TorButton=true returns
<html xmlns="http://www.w3.org/1999/xhtml"><body><a id="TorCheckResult" target="success" href="/"></a></body></html>
for me, and I've checked that I'm not leaking DNS queries but I still get the failure message. The only odd thing I am doing is still using Privoxy rather than Polipo.
Maybe this should be changed to a bug. In the meantime, how do I get the warning message every time I enable Tor to go away?

comment:3 Changed 10 years ago by downie

stripped the HTML I see; trying again

https://check.torproject.org/?TorButton=true returns
&lt;html xmlns="http://www.w3.org/1999/xhtml"&gt;&lt;body&gt;&lt;a id="TorCheckResult" target="success" href="/"&gt;&lt;/a&gt;&lt;/body&gt;&lt;/html&gt;
for me, and I've checked that I'm not leaking DNS queries but I still get the failure message. The only odd thing I am doing is still using Privoxy rather than Polipo.
Maybe this should be changed to a bug. In the meantime, how do I get the warning message every time I enable Tor to go away?

comment:4 Changed 10 years ago by downie

To answer my last question:
in about:config , reset
'extensions.torbutton.test_failed'
to false.

comment:5 Changed 9 years ago by mikeperry

Description: modified (diff)
Resolution: Noneworksforme
Status: newclosed

I think this warning should go away if you just rerun the test.

Note: See TracTickets for help on using tickets.