Opened 5 years ago

Closed 5 years ago

#11094 closed defect (not a bug)

Router - LAN - Tor Relay Server ... as LAN Proxy, too

Reported by: 26498 Owned by:
Priority: Medium Milestone:
Component: - Select a component Version: Tor: 0.2.4.20
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi

I have a problem with my local TOR-Relay-Server.
The Server is a Debian-Server within my LAN, behind a NAT-Router (Port-Forwarding). It works fine so far, but I wanne use it as a local Proxy for all my devices within the LAN.
I think I've tried everything, but TORLog says

"[WARN] Rejecting SOCKS request for anonymous connection to private address [scrubbed]."

I tried to connect via Tor-Browser (connection timed out)

My actual config

Torrc:
SocksPort 10.0.0.101:7060
SocksPolicy accept *

TestPC 10.0.0.100

arm message:
[NOTICE] You configured a non-loopback address '10.0.0.101:7050' for SocksPort. This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.

And the next message:
[WARN] Rejecting SOCKS request for anonymous connection to private address [scrubbed].

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by nickm

Resolution: not a bug
Status: newclosed

That warning means that Tor won't accept attempts to send private addresses, like "10.x.y.z", over the Tor network. (It wouldn't make sense: instead of getting 10.x.y.z as it exists on _your_ network, you would be trying to access 10.x.y.z on some Tor exit node's network.)

The best move here is probably to configure your proxy code so that only non-private addresses are sent over Tor. If you're not sure how to do that, you should be able to get more help on one of the mailing lists, or from the support desk at help@…, or on the IRC channel (if you're patient).

Best wishes!

Note: See TracTickets for help on using tickets.