Opened 5 years ago

Closed 5 years ago

#11097 closed enhancement (not a bug)

CHACHA20_POLY1305

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Internal Services/Tor Sysadmin Team Version:
Severity: Keywords:
Cc: Sebastian Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Support CHACHA20_POLY1305 TLS v1.2 as default cipher on the websites.

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by nickm

I'm +1 on this once our TLS implementations supports it. (AFAICT the CHACHA20_POLY1305 ciphersuites doesn't have official assigned numbers yet and hasn't been merged into mainline openssl.)

comment:2 Changed 5 years ago by arma

Seems like this will only happen once it gets into debian stable, yes? I don't think we should run a non-standard webserver just so non-standard browsers could in theory interact with it that way.

comment:3 Changed 5 years ago by Sebastian

Cc: Sebastian added
Component: WebsiteTor Sysadmin Team

This is for the sysadmins to decide.

comment:4 Changed 5 years ago by weasel

Resolution: not a bug
Status: newclosed

We will revisit ciphersuites once we moved to Debian jessie.

Note: See TracTickets for help on using tickets.