Opened 6 years ago

Closed 3 years ago

#11105 closed defect (duplicate)

Open new tab/window open a firefox tab/window

Reported by: br1 Owned by:
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Instead of obviously a tor tab/window, when right-clicking on the tor browser bundle icon of the task bar, and then selecting new tab/window.

Child Tickets

Change History (12)

comment:1 Changed 6 years ago by gk

Component: - Select a componentTor bundles/installation
Status: newneeds_information

What is the bug/feature request here? Could you please elaborate?

comment:2 Changed 6 years ago by brb

It was a bug report.
Doing what I said, I had a firefox window opening when it should have been a tor one.

I updated to 3.5.3 yesterday and tested if the problem was still here. It seems that the problem is a confusing between tor and firefox. If I open tor first, trying to open firefox creates a tor window ; while if I open firefox first, tor opens a firefox window... (Using desktop shortcuts for both)

A quick guess is that it is related to some folder being used by both.

If you need more details just ask. I don't know what really would be relevant.

comment:3 Changed 6 years ago by cypherpunks

If you need more details just ask. I don't know what really would be relevant.

Is it Windows? Windows8?

comment:4 Changed 6 years ago by cypherpunks

Using desktop shortcuts for both

Are you sure link target for TorBrowser is "Start Tor Browser.exe"?
Did you changed "Start In" (working directory) field?
What vanilla Firefox version installed?

comment:5 Changed 6 years ago by brb

-I use Windows 8
-Seems that not : using "start tor browser.exe" always open tor even if firefox is opened before. I was somehow unaccurate in my description : I pinned tor to the task bar for quick access which is not really the same than a desktop link. It seems that the oddity I describe in my previous comment is linked to this (firefox however is launched from the desktop as I said)
-Didn't change the "start in" from what I know
-I have Firefox 28, 27 at the time of the ticket creation

-The problem described in the ticket remains exactly the same with "start tor browser.exe" (I used that at the time I created the ticket and it didn't change).

The whole problem seems to be linked with task bar behaviors.

Last edited 6 years ago by brb (previous) (diff)

comment:6 Changed 6 years ago by cypherpunks

Problem is that pinning is simple link to executable file. Like for example: for Torbrowser was created link stored in "C:\Users\<UserName>\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar\TorBrowser.lnk". If to open link to edit it show target is "C:\Users\<UserName>\Tor Browser\Browser\firefox.exe", without command line arguments used by "Start Tor Browser.exe" to start Torbrowser properly.

Don't pin Torbrowser window, it's unsafe.

comment:7 Changed 6 years ago by cypherpunks

#4192 was about to prevent shooting in the foot.
Due changes in code now it's #8350

comment:8 Changed 6 years ago by cypherpunks

Btw, even to fix link so it included all stuff. Commands to open window/tab still working independently and affect first open browser, and vanilla Firefox still occupying Torbrowser window if started second.

This Windows UI problem is similar to #10730 and #11102 for gnome. Need to say Windows that browsers are different so it never messed them.

Last edited 6 years ago by cypherpunks (previous) (diff)

comment:9 Changed 6 years ago by cypherpunks

Possible directly to prevent pinning of Torbrowser.
Code sample: https://blogs.msdn.com/b/oldnewthing/archive/2011/06/01/10170113.aspx

comment:10 Changed 6 years ago by cypherpunks

Together with prevent pinning need to disable all taskbar options and commands for Windows. "Open new tab/window" command can't to work properly for TBB which runs with "-no-remote" (Do not accept or send remote commands) option, and confusing users by opening tab/window for vanilla Firefox if those running too.

It can be done with next preference (presents only for Windows' builds):
browser.taskbar.lists.enabled
browser.taskbar.lists.frequent.enabled
browser.taskbar.lists.recent.enabled
browser.taskbar.lists.tasks.enabled
browser.taskbar.previews.enable

Last edited 6 years ago by cypherpunks (previous) (diff)

comment:11 Changed 5 years ago by cypherpunks

Component: Tor bundles/installationTor Browser

Is this still an issue with the latest release?

comment:12 Changed 3 years ago by bugzilla

Resolution: duplicate
Severity: Normal
Status: needs_informationclosed

#9285 is a duplicate.
#13428 is a duplicate.

Closed as a duplicate of #12885.

Note: See TracTickets for help on using tickets.