Opened 4 years ago

Closed 4 years ago

#11168 closed defect (not a bug)

TorBirdy still running when disabled / no uninstall/remove button in GUI

Reported by: cypherpunks Owned by: ioerror
Priority: Low Milestone:
Component: Applications/TorBirdy Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm using debian wheezy/icedove and enigmail as only other add-on. My gmail got locked down and they forced a password change. I disabled TorBirdy for entering the new password, but although shown as disabled, I still get the "The proxy server is refusing connections" message in the add-ons manager and the connection to the mail server gets refused, unless I'm running tor as well. I tried icedove in safe-mode, with all add-ons disabled with the same result. There is also no uninstall/remove button on TorBirdy in the add-ons manager. I had TorBirdy previously disabled and re-enabled without any problems, so the issue occurred suddenly. Of course I can manually remove TorBirdy, but I left it as is for now, so if you someone tells me how to provide further information on how to re-create I'll be happy to. I'm not too savvy so it might be improper usage, but my debian install is fresh and I did not configure much.

Child Tickets

Attachments (1)

torbirdy.png (59.2 KB) - added by cypherpunks 4 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 in reply to:  description ; Changed 4 years ago by sukhbir

Replying to cypherpunks:

I'm using debian wheezy/icedove and enigmail as only other add-on. My gmail got locked down and they forced a password change.

Yes, sadly, that's expected with Gmail accounts. There is a way to fix this issue; have a look at the TorBirdy with Gmail section in the manual.

I disabled TorBirdy for entering the new password, but although shown as disabled, I still get the "The proxy server is refusing connections" message in the add-ons manager and the connection to the mail server gets refused, unless I'm running tor as well

That's odd.

I tried icedove in safe-mode, with all add-ons disabled with the same result. There is also no uninstall/remove button on TorBirdy in the add-ons manager.

If you right click on it, there should be an option to uninstall and disable it.

I had TorBirdy previously disabled and re-enabled without any problems, so the issue occurred suddenly. Of course I can manually remove TorBirdy, but I left it as is for now, so if you someone tells me how to provide further information on how to re-create I'll be happy to. I'm not too savvy so it might be improper usage, but my debian install is fresh and I did not configure much.

So a quick question: which version of TorBirdy and Icedove are you using?

Changed 4 years ago by cypherpunks

Attachment: torbirdy.png added

comment:2 in reply to:  1 Changed 4 years ago by cypherpunks

Replying to sukhbir:

Yes, sadly, that's expected with Gmail accounts. There is a way to fix this issue; have a look at the TorBirdy with Gmail section in the manual.

I found that and it worked, I can log in from the tor browser now, thanks.

If you right click on it, there should be an option to uninstall and disable it.

Nope, only disable, no uninstall, I added a screenshot as attachment. And when I disable the connection still gets refused unless I'm running tor as well.

So a quick question: which version of TorBirdy and Icedove are you using?

TorBirdy 0.1.2 and Icedove 17.0.10

comment:3 Changed 4 years ago by sukhbir

Looking at the screenshot, it seems like TorBirdy is disabled. Is this expected?

If yes and if you disabled TorBirdy, it should clear your proxy settings. If that is not happening, look at the proxy settings to see if there is some other value being set or the value is not being cleared? (Edit > Preferences > Advanced > Networks and Disk Space > Settings).

Also, use Ctrl + Shift + J to bring up the error console and see if you get any error message when disabling TorBirdy.

comment:4 Changed 4 years ago by cypherpunks

It was disabled on purpose, but my proxy settings indeed were for some reason set to manual. I set it to "auto-detect" and now everything works as expected again. That was stupid of me not to check, sorry :(

comment:5 Changed 4 years ago by sukhbir

Oh no problem, it happens! If you think that the issue is resolved, you can close the ticket.

comment:6 Changed 4 years ago by cypherpunks

Resolution: not a bug
Status: newclosed

Thanks. Best Wishes and Regards.

Note: See TracTickets for help on using tickets.