Opened 10 years ago

Closed 3 years ago

#1117 closed defect (fixed)

bridge authorities mark every bridge stable+guard

Reported by: arma Owned by: sysrqb
Priority: Very Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version: 0.2.1.19
Severity: Normal Keywords: performance bridges tor-bridge TorCoreTeam201605
Cc: arma, nickm, karsten Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by nickm)

Tonga lists every bridge as Stable and Guard.

Nick suggests this is because "bridge authorities don't count a
bridge as having Failed for MTBF purposes when they find it to be
non-Running"

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Change History (17)

comment:1 Changed 9 years ago by nickm

This *ought* to be as simple as adding appropriate calls to the rephist_note_* commands in our bridge testing code.

comment:2 Changed 9 years ago by nickm

Description: modified (diff)
Milestone: Tor: 0.2.3.x-final
Priority: minortrivial

one question though... does this actually affect anything? It seems totally harmless.

comment:3 Changed 9 years ago by arma

Priority: trivialnormal

bridgedb has rules like "make sure at least one of the bridges you give out has the Stable flag". So since they all do, that rule is moot.

(It's possible this feature never got implemented, or not implemented like that. See #1606.

comment:4 Changed 9 years ago by arma

Component: Tor RelayTor Bridge

comment:5 Changed 8 years ago by arma

Keywords: performance bridges added

comment:6 Changed 8 years ago by nickm

Milestone: Tor: 0.2.3.x-finalTor: unspecified

comment:7 Changed 7 years ago by nickm

Priority: normaltrivial

comment:8 Changed 7 years ago by nickm

Keywords: tor-bridge added

comment:9 Changed 7 years ago by nickm

Component: Tor BridgeTor

comment:10 Changed 6 years ago by sysrqb

I don't think this is true anymore...close?

comment:11 Changed 6 years ago by arma

Still true.

Show me a bridge that has the Running and Valid flag, in Tonga's bridge networkstatus file, that doesn't also have the Fast, Guard, and Stable flags?

comment:12 Changed 6 years ago by sysrqb

Ah ha! That isn't what I thought this was.

Indeed it does appears that Running and Valid imply Fast Guard Stable.
Small snippet (but it holds true for the rest).

s Fast Guard Running Stable Valid
s Valid
s Fast Guard Running Stable Valid
s Fast Guard Running Stable Valid
s Fast Guard Running Stable Valid
s Fast Guard Running Stable Valid
s
s Fast Guard Running Stable Valid
s Fast Guard Running Stable Valid
s Fast Guard Running Stable Valid
s Running
s Fast Guard Running Stable Valid
s Fast Guard Running Stable Valid
s Valid
s Valid

comment:13 Changed 6 years ago by arma

Cc: arma,nickm,karstenarma, nickm, karsten

#9859 says that it fixed this bug.

Are we leaving the ticket open until we've put out 0.2.5.2-alpha, Tonga has upgraded, and we've confirmed? If that's the case, it sounds like a better plan would be to close the ticket because we think we fixed the bug, and reopen it later if needed.

(Also, yay!)

comment:14 Changed 3 years ago by arma

Resolution: Nonefixed
Severity: Normal
Status: newclosed

I just checked a networkstatus from Tonga and this one looks good. Closing!

comment:15 Changed 3 years ago by arma

Resolution: fixed
Status: closedreopened

comment:16 Changed 3 years ago by arma

Owner: set to sysrqb
Status: reopenedassigned

comment:17 Changed 3 years ago by arma

Keywords: TorCoreTeam201605 added
Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.