Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#11194 closed defect (duplicate)

Tor Browser detected screen size is different than Firefox

Reported by: joebt Owned by: erinn
Priority: High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: Tor Browser, screen size
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Now using TBB 3.5.2 (Windows).
I see "odd" (unusual) screen sizes reported / detected for TBB browser tests - at several sites (browserspy.dk, panopticlick, ip-check.info).
Like showing 1920 x 966 (or 963,etc.).  This stands out like a sore thumb.  It is also affected in Windows by 2 system settings.

1) When Windows system DPI * IS * set @ default 96 DPI.
2) When the system DPI is NOT the default value (many users MUST set DPI larger, to read various screens. Ex.: both Windows' & apps' UI & Help screens, etc.

With system DPI @ 96.  At the same time as testing TBB, regular Fx (no "privacy addons" hiding / spoofing browser data), all the test sites show 1920 x 1080 for Fx. 

That is w/ EXACT same toolbars & other UI elements displayed in both browsers, where test sites show odd values for TBB - 1920 x 966 (or what ever).  Not good.

The "966 or 967" TBB screen height (or whatever odd number), turns out to be the height for the part of browser window, beginning just below the browser navigation bar, down to the top of "Addon Bar."

However, in regular Fx , the test sites show screen size of the full monitor: 1920 x 1080, not just the "usable display area" of the browser pane (the part of browser window where websites actually display).

2nd Case:  When system DPI is NOT at default 96.

Not sure anything can be done, so sites monitoring screen size (TBB or any browser) don't see odd sizes, when the system DPI is @ NON-default value?  But, even in that case (say, DPI -  110), the test sites STILL show different screen sizes for TBB vs Fx (27).  So all Fx & TBB users that set the system DPI @ 100, 110..., sites that check will see different values for TBB vs. Fx.  Again, not good.

See comments 10 & 11: https://trac.torproject.org/projects/tor/ticket/7256#comment:10

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by gk

Resolution: duplicate
Status: newclosed

See #7256 which you referred to:

However, this potentially leaks information for users who maximize their browser windows, as such windows will no longer be rounded.

Marking this as a duplicate of #7256.

comment:2 Changed 6 years ago by joebt

In context of this issue, what's the definition / implication of the category "Project?"

The reason I filed it here (right or wrong), is because many would consider this a bug, not something we'll get around to if we ever get caught up. Maybe I misunderstand the meaning of "project."

When I visit panopticlick w/ TBB 3.5.2, due to the odd screen size (specifically, the height - of 982 or similar), it shows 1 browser in 10's or 100's of thousands has that value (pretty unique).

At the same time in regular Fx (same default theme, same toolbars, etc.), it detects 1920 x 1080 screen size (if Windows system is set @ 96 DPI). Panopticlick shows 1 browser in 46 have that screen size (quite common). That difference alone suggests this is a real TBB bug.

If I want to anonymously release some "important" data to the media, how much easier is it to start looking for a (Tor) browser w/ screen size 1 in 100's of thousands vs. 1 in 40 or 50? To ask my very large ISP, "give us a list of users that accessed Tor relays last Fri between 9:00 & 9:05" (the approx. time a TBB user w/ the really odd screen size accessed a particular site from a specific Tor exit).

Note: See TracTickets for help on using tickets.