Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11199 closed defect (fixed)

Improve Tor Launcher's behavior if tor exits

Reported by: mcs Owned by: mcs
Priority: Medium Milestone:
Component: Applications/Tor Launcher Version:
Severity: Keywords: TorBrowserTeam201407
Cc: brade, mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Currently, if tor exits (due to a crash or kill signal), Tor Launcher just displays an error alert that reads "Tor unexpectedly exited." To restore the ability to browse, users must quit the browser and restart it themselves.

Maybe Tor Launcher should offer to restart tor. Vidalia provides a clear indication of status ("Tor is not running") as well as a "Start Tor" button.

Child Tickets

Attachments (3)

prompt-tor-exited.png (23.4 KB) - added by brade 5 years ago.
screenshot of prompt
network-settings-tor-exited.png (41.2 KB) - added by brade 5 years ago.
Network Settings window after tor exited
prompt-tor-exited-2.png (36.8 KB) - added by brade 5 years ago.
Revised prompt

Download all attachments as: .zip

Change History (14)

comment:1 Changed 5 years ago by mcs

Keywords: TorBrowserTeam201407 added

Also see #12440 (Tell users that "Tor unexpectedly exited" is not so bad.)

Changed 5 years ago by brade

Attachment: prompt-tor-exited.png added

screenshot of prompt

Changed 5 years ago by brade

Network Settings window after tor exited

comment:2 Changed 5 years ago by brade

Resolution: fixed
Status: newclosed

This is now fixed. If Tor Launcher started the tor process and it exits, we now display
a prompt that allows the user to restart tor. Within the Network Settings window, a similar "Restart Tor" feature is available.

https://gitweb.torproject.org/tor-launcher.git/commit/b152a6ed537d08824782b9535daa7c8113418782

I also attached a couple of screenshots so other people can see what the interface looks like.

comment:3 Changed 5 years ago by lunar

I'm not sure I understand when these screenshot appears.

Re “prompt-tor-exited.png”, I believe “Cancel” should be something else. The current dialog gives me no idea about what will happen when clicking that button.

Re “network-settings-tor-exited.png”, this is really dry. An array of possible reasons for why this happened, and how it affects the user might be good additions.

comment:4 Changed 5 years ago by brade

The cancel/reconnect prompt is shown as a modal dialog right after tor exits. It will be placed over the browser window like an error alert. The other screenshot shows the Network Settings dialog when tor is not running. I assume that tor exiting is very rare except when the user intentionally kills tor.

Regarding cancel, users know it is a "safe" option. I am open to other suggestions. Clicking cancel will leave the browser in its current state (tor is not running). This will allow users to copy text or take a screenshot or otherwise examine their browser tabs before they restart tor or TBB.

For the 2nd screenshot, I am willing to add more text if someone proposes it. I'm not sure what reasons tor might be exiting; I haven't been able to reproduce the bug some users see when tor exits during startup. We could add the following text below "Tor unexpectedly exited":

To continue browsing, you will need to restart Tor.

comment:5 in reply to:  4 ; Changed 5 years ago by lunar

Thanks for your answers.

Replying to brade:

The cancel/reconnect prompt is shown as a modal dialog right after tor exits. It will be placed over the browser window like an error alert. The other screenshot shows the Network Settings dialog when tor is not running. I assume that tor exiting is very rare except when the user intentionally kills tor.

Regarding cancel, users know it is a "safe" option. I am open to other suggestions. Clicking cancel will leave the browser in its current state (tor is not running). This will allow users to copy text or take a screenshot or otherwise examine their browser tabs before they restart tor or TBB.

Maybe the label could be “Continue in offline mode” or “Switch to offline mode” instead of “Cancel”, then? Because in effect, they won't be able to reach any sites. “Cancel” implies that the user asked the browser to perform some action and can back off. But in the present case, they didn't ask Tor to quit. :)

For the 2nd screenshot, I am willing to add more text if someone proposes it. I'm not sure what reasons tor might be exiting; I haven't been able to reproduce the bug some users see when tor exits during startup. We could add the following text below "Tor unexpectedly exited":

To continue browsing, you will need to restart Tor.

Maybe something like “Tor unexpectedly exited. This might be because of a bug in Tor itself, some other program on your system, or faulty hardware. You are currently in offline mode: the Tor Browser is not able to reach any websites when Tor is not running. If the problem persists, please send the log messages to the support team.”

I'm not 100% sure, but you get the idea.

comment:6 Changed 5 years ago by cypherpunks

I'm using system-wide tor. What will happen if it exits or if I try to reconnect?

comment:7 in reply to:  6 Changed 5 years ago by mcs

Replying to cypherpunks:

I'm using system-wide tor. What will happen if it exits or if I try to reconnect?

Tor Launcher only monitors tor if it was started by Tor Launcher itself, so if you are using a system-wide tor the prompts mentioned in this bug will not be displayed.

comment:8 in reply to:  5 ; Changed 5 years ago by brade

Replying to lunar:

Maybe the label could be “Continue in offline mode” or “Switch to offline mode” instead of “Cancel”, then? Because in effect, they won't be able to reach any sites. “Cancel” implies that the user asked the browser to perform some action and can back off. But in the present case, they didn't ask Tor to quit. :)

I don't think it's a good idea to switch users to Firefox's offline mode or to use the term "offline" when not referring to that feature. It seems like that could lead to a lot of support questions (some users will know about offline mode and some won't; those who do will try to get for working by unchecking "Work Offline" while those who don't will ask support about that feature). If we do switch users to Firefox's offline mode, we would need to modify the browser so that switching in and out of offline mode causes the right thing to happen. It would be a lot of development effort to catch all of the edge cases involved with offline mode.

So, we need something else for the "Cancel" button. We just need a way for people to acknowledge that tor exited if they choose not to reconnect/restart. My best idea is to replace "Cancel" with "OK" or "Acknowledged." For consistency, the other button would be labeled "Restart Tor" and it will remain the default button.

Maybe something like “Tor unexpectedly exited. This might be because of a bug in Tor itself, some other program on your system, or faulty hardware. You are currently in offline mode: the Tor Browser is not able to reach any websites when Tor is not running. If the problem persists, please send the log messages to the support team.”

I'm not 100% sure, but you get the idea.

How about:

Tor unexpectedly exited. This might be due to a bug in Tor itself, another program on your system, or faulty hardware. Until you restart Tor, the Tor Browser will not able to reach any websites. If the problem persists, please send a copy of your Tor Log to the support team.

I will attach an updated screenshot.

Changed 5 years ago by brade

Attachment: prompt-tor-exited-2.png added

Revised prompt

comment:9 in reply to:  8 Changed 5 years ago by mcs

Replying to brade:

How about:

Tor unexpectedly exited. This might be due to a bug in Tor itself, another program on your system, or faulty hardware. Until you restart Tor, the Tor Browser will not able to reach any websites. If the problem persists, please send a copy of your Tor Log to the support team.

Lunar (or others) -- do you have any comments on this proposal? We (brade and me) would like to proceed with it or a similar improved UI ASAP so there is still time for new strings to be translated before TB 4.0 reaches beta.

comment:10 Changed 5 years ago by lunar

Feels better than the original wording to me. Mh… Maybe we could add something about the fact that restarting Tor in not the same as restarting the Tor Browser and that the current session will be kept open just like it is? Otherwise people might click Cancel by fear of loosing their open tabs.

comment:11 Changed 5 years ago by mcs

Thanks for your feedback. We added "Restarting Tor will not close your browser tabs." and committed these improvements.

https://gitweb.torproject.org/user/brade/tor-launcher.git/commitdiff/3aa4860244adf99ba09911708ba8faa05a6cfa14

Note: See TracTickets for help on using tickets.