Opened 10 years ago

Closed 9 years ago

#1120 closed enhancement (duplicate)

Private Browsing mode enforces Tor switched on

Reported by: TonyTor Owned by:
Priority: Low Milestone:
Component: Applications/Torbutton Version: 0.2.1.19
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description (last modified by mikeperry)

First of all, let me thank you for your wonderful work. Privacy matters!

Recently, Firefox received a private browsing mode.
I propose an additional configuration option for Tor button, that enforces that Tor is enabled in private browsing mode.
You're hitting CTRL-SHIFT-P and get the private browsing in conjunction with Tor.
You already seem to have provisions to enforce the Tor button's state.
What's probably missing is the hook in private browsing function of Firefox.

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Change History (2)

comment:1 Changed 10 years ago by mikeperry

This is planned for an alpha release in early December.

comment:2 Changed 9 years ago by mikeperry

Component: Torbutton-Tor clientTor - Torbutton
Description: modified (diff)
Resolution: Noneduplicate
Status: newclosed

Duplicate of #1515.

Private browsing shouldn't turn on Tor, but Torbutton should have an option to turn on private browsing mode whenever enabled.

Note: See TracTickets for help on using tickets.