Opened 5 years ago

Closed 3 years ago

#11209 closed defect (duplicate)

Tor Browser: middlemouse.contentLoadURL should be disabled per default, because it's way too easy to trigger it accidentially

Reported by: blubber Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-firefox-patch
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I suggest middlemouse.contentLoadURL to be disabled per default, since I *always* accidentially middle mouse click at some point when scrolling, even more so with my trackpoint. In my regular firefox I have disabled this behaviour, but it's all too easy to forget with the tor browser.

Because it can be easily enabled by people that rely on it and because text middle mouse pasting still works as expected when this is disabled, I suggest middlemouse.contentLoadURL is set to false (current default: true) to avoid users accidentially going to URLs which may reveal their identity.

(The problem really isn't the middle mouse pasting by itself, but that firefox/tor browser will also instantly load up the page without any additional confirmation)

Child Tickets

Change History (3)

comment:1 in reply to:  description Changed 5 years ago by gk

Replying to blubber:

I suggest middlemouse.contentLoadURL to be disabled per default, since I *always* accidentially middle mouse click at some point when scrolling, even more so with my trackpoint. In my regular firefox I have disabled this behaviour, but it's all too easy to forget with the tor browser.

Because there is no auto-updater yet or is there another reason why the Tor Browser case is different for you?

Last edited 5 years ago by gk (previous) (diff)

comment:2 Changed 5 years ago by erinn

Component: Firefox Patch IssuesTor Browser
Keywords: tbb-firefox-patch added
Owner: changed from mikeperry to tbb-team

comment:3 Changed 3 years ago by gk

Resolution: duplicate
Severity: Normal
Status: newclosed

Duplicate of #10089.

Note: See TracTickets for help on using tickets.