Opened 6 years ago

Closed 5 years ago

#11260 closed defect (duplicate)

ASSERTIONs in font-face related code

Reported by: gk Owned by: mikeperry
Priority: High Milestone:
Component: Firefox Patch Issues Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I get assertions when requesting https://code.google.com/codejam/contest/registration:

###!!! ASSERTION: bad font face url passed to fontloader: 'aFontFaceSrc && !aFontFaceSrc->mIsLocal', file /home/firefox/tor-browser/layout/style/nsFontFaceLoader.cpp, line 821
###!!! ASSERTION: null font uri: 'aFontFaceSrc->mURI', file /home/firefox/tor-browser/layout/style/nsFontFaceLoader.cpp, line 822
###!!! ASSERTION: bad font face url passed to fontloader: 'aFontFaceSrc && !aFontFaceSrc->mIsLocal', file /home/firefox/tor-browser/layout/style/nsFontFaceLoader.cpp, line 821
###!!! ASSERTION: null font uri: 'aFontFaceSrc->mURI', file /home/firefox/tor-browser/layout/style/nsFontFaceLoader.cpp, line 822
###!!! ASSERTION: bad font face url passed to fontloader: 'aFontFaceSrc && !aFontFaceSrc->mIsLocal', file /home/firefox/tor-browser/layout/style/nsFontFaceLoader.cpp, line 821
###!!! ASSERTION: null font uri: 'aFontFaceSrc->mURI', file /home/firefox/tor-browser/layout/style/nsFontFaceLoader.cpp, line 822
###!!! ASSERTION: bad font face url passed to fontloader: 'aFontFaceSrc && !aFontFaceSrc->mIsLocal', file /home/firefox/tor-browser/layout/style/nsFontFaceLoader.cpp, line 821
###!!! ASSERTION: null font uri: 'aFontFaceSrc->mURI', file /home/firefox/tor-browser/layout/style/nsFontFaceLoader.cpp, line 822

This does not happen in a vanilla 24.4.0 ESR.

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #9018.

Note: See TracTickets for help on using tickets.