Opened 5 years ago

Closed 5 years ago

#11288 closed defect (not a bug)

Tor not working on my Windows 8.1 based laptop due to IPv6

Reported by: RagingRhino Owned by:
Priority: High Milestone:
Component: Archived/general Version: Tor: 0.2.5.3-alpha
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

(NOTE: Fixed Problem by disabling IPv6 in Windows)
(This is the problem copy/pasted from a forum I posted on asking for help)
(Posts seperated by '..............')
(I hope this helps some other people...)


I usually access .onions with TOR browser bundle on my Windows 7 Ultimate 64bit PC just fine,

BUT I just bought a laptop, which I want to use TOR on.

Firstly it came with shity Windows 8.1 software: I tried downloading the TOR BRowser bundle and installing. I could access google.com and anyother normal website, but every single .onion website wouldn't load. it kept saying:

" Unable to connect
Firefox can't establish a connection to the server at xxxxxxx.onion"

For every onion site. They are not down, as I am simultaneously on those sites on my PC.

I tried installing VirtualBox and running an ubuntu OS in there, but that went to shit as the guide was too old.

So I formatted the laptop, and installed Windows 7 Ultimate 64 bit again on the laptop. After a bunch of driver problems because my laptops a crappy lenovo ideapad flex 15D, I managed to get most of the laptop working fine under Windows 7 (except Ethernet and my SD Card reader, oh well).

I tried installing TOR again, and surprise surprise I am getting the same error on every single .onion

I have tried googling this for 6 hours, and have tried the usual set my laptops clock to the correct time to the second/set it forward an hour, turn off my firewall completely to see if that was the problem etc...

oh yeh.. TOR loads up perfectly, and connects to the check.torproject.org homepage just fine... says 'Congratulations. This Browser is configured to use or.' and shows my IP address etc.... it just won't connect to ANY onion sites.

...................................................

Every setting I can see is exactly the same as my main PC. Besides i did a few tests with the 'time thing', and that brings up the 'time out' error, not the 'Firefox can't establish a connection' error....

I am completely lost. The only thing that is now different about the laptop and the PC is that the laptop was 'designed' for windows 8 not 7 (hence why some of my drivers won't work, because there are ONLY windows 8+ drivers, therefore there is a slight incompatability with some of my hardware.

But I doubt its a 'driver conflict' as TOR was doing exactly the same thing when Windows 8.1 OS was installed from manufacturer, on the laptop.

I just tried running the laptop in 'SAFE MODE' too, but again Tor did the same thing... so annoying

................................................

Tried both rebooting, TBB reinstall. I've tried older versions of the Bundle, i've tried the latest, i've tried the 2.6 beta version.... I've tried running through bridges... it's driving me bananas!

................................................

* Another user replied with the following suggestion*

If tor or i2p don’t work for you on host os, the same should be on VM. I suggest you try live usb, so you get a tip if that is windows or some hardware problem.
Also if windows use IPv6 try to change to IPv4.

.................................................

I just used the hotfix from http://support.microsoft.com/kb/929852 to disable iPv6 (first option)...

...................................................

I am so happy I could jump you right now!!! The IPv4 thing worked!!! woooooopppppp wooooppppppppp.... just synced my time with windows after disabling IPv6 in Windows, and booom I can access Evo!!!!! mwwahhaahhhaaaaaaaaa

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by cypherpunks

Seems like problem wasn't about IPv6 itself but about timezone. While clock was correct, timezone was incorrect.

comment:2 Changed 5 years ago by arma

Sounds like close as not-a-bug?

comment:3 Changed 5 years ago by nickm

Resolution: not a bug
Status: newclosed

Right; we really do need an accurate clock.

Note: See TracTickets for help on using tickets.