Opened 6 years ago

Closed 6 years ago

#11296 closed defect (fixed)

Missing include breaks build of tor-fw-helper in 0.2.5.3

Reported by: hiviah Owned by:
Priority: Medium Milestone: Tor: 0.2.5.x-final
Component: Core Tor/Tor Version: Tor: 0.2.5.3-alpha
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

If you use "./configure --enable-upnp && make", build with break on missing siphash.h in tor-fw-helper:

  CC       src/tools/tor-fw-helper/src_tools_tor_fw_helper_tor_fw_helper-tor-fw-helper.o
In file included from src/tools/tor-fw-helper/tor-fw-helper.c:25:
./src/common/container.h:10:21: error: siphash.h: No such file or directory

Seems that -I$(srcdir)/src/ext is required somewhere.

Child Tickets

Change History (5)

comment:1 Changed 6 years ago by nickm

Keywords: tor-client added
Milestone: Tor: 0.2.5.x-final

comment:2 Changed 6 years ago by nickm

Status: newneeds_review

Possible bugfix in branch "bug11278"

Edit: whoops; wrong ticket.

Last edited 6 years ago by nickm (previous) (diff)

comment:3 Changed 6 years ago by nickm

Does my branch "bug11296" fix this for you?

comment:4 Changed 6 years ago by hiviah

Yes, it fixes the problem with building tor-fw-helper.

The build breaks on generating documentation, which I can't quite understand how it can be affected by the added include from patch (this does not occur without --enable-upnp):

  GEN    doc/tor-resolve.1
  GEN    doc/torify.1
config.status: error: cannot find input file: doc/torify.1.in
make[1]: *** [doc/torify.1] Error 1
make[1]: Leaving directory `/home/ondro/tmp/tor.clean'
make: *** [all] Error 2

I tried to randomly insert the include at various places, but still get the failure with documentation generation.

When crosscompiling using openwrt buildroot, it gives wholly different and more confusing error about automake-1.13 missing, just after applying the bug11296 branch patch. I'll try looking into a bit more, but currently I can't see a specific cause for it right now.

comment:5 Changed 6 years ago by nickm

Resolution: fixed
Status: needs_reviewclosed

I've merged bug11296, and opened #11321 to track the other issue. I have a fix for that too.

Note: See TracTickets for help on using tickets.