Opened 5 years ago

Closed 5 years ago

#11303 closed defect (not a bug)

TorBrowserBundle-3.5.3 no longer accepts any cookies or remembers any history

Reported by: jake Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-usability
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The latest upgrade (TorBrowserBundle-3.5.3-osx32_en-US /
Firefox ESR 24.4.0) has flipped its privacy policy from
remembering history to not remembering history and it also
no longer accepts any cookies at all so logging into
websites that require cookies is now impossible.

The previous version (TorBrowserBundle-3.5.2-osx32_en-US /
Firefox ESR 24.3.0esrpre) did remember history and did accept
cookies.

This looks like a bug from here. The design document only
says that third party cookies are not to be accepted.

Child Tickets

Change History (5)

comment:1 Changed 5 years ago by gk

Keywords: tbb-usability added
Version: Tor: unspecified

Works for me. And no, there has been no flip in the privacy policy. How did you come to this conclusion? And why do you assume that it no longer accepts cookies (which it does on my machine)? Tested with a freshly downloaded en-US bundle on 10.6.

comment:2 Changed 5 years ago by gk

To be clear on the privacy policy part: we are using the Private Browsing Mode by default which should result in a "Never remember history" in the Tor Browser settings.

comment:3 Changed 5 years ago by jake

I came to the conclusion that there had been a flip in the privacy policy
by observing the fact that whenever I started TorBrowserBundle-3.5.2 and
looked at the privacy tab in the preferences dialog, it says:

TorBrowser will: Remember History

However, when I do the same thing with TorBrowserBundle-3.5.3, it says:

TorBrowser will: Never Remember History

instead. From what you say, perhaps that was a bug in 3.5.2.

As for no longer accepting cookies, that is not an assumption but another
observation. Specifically, when I visit a site that I know uses cookies
(such as google) in TorBrowserBundle-3.5.2, and click on the Tor button
and select the cookie protections menu item, it would present me with a
dialog box that showed me the current list of cookies and there would be
cookies displayed there. However, when I do the same thing in
TorBrowserBundle-3.5.3, the cookie protections dialog box appears with the
part that displays the current list of cookies is always empty.

In addition to that, whenever I try to log into a website that uses cookies
for logging in (e.g. ebay), it doesn't work. It just returns me to the
preceding page with the "sign in" links still present (which aren't there
when the user is signed in). That was the dead giveaway that made me look
at the cookie protections dialog in the first place.

Anyway, I'm happy that it works for you.
Now, any idea why it's not working for me?

By the way, the behaviour I'm seeing occurs on two separate macosx-10.6.8
laptops.

comment:4 in reply to:  3 ; Changed 5 years ago by gk

Replying to jake:

I came to the conclusion that there had been a flip in the privacy policy
by observing the fact that whenever I started TorBrowserBundle-3.5.2 and
looked at the privacy tab in the preferences dialog, it says:

TorBrowser will: Remember History

However, when I do the same thing with TorBrowserBundle-3.5.3, it says:

TorBrowser will: Never Remember History

instead. From what you say, perhaps that was a bug in 3.5.2.

Well, I don't think so. There (fresh 3.5.2.1) I still see a Never Remember History. Not sure what was wrong. Maybe you disabled the Private Browsing Mode due to login problesm with TBB 3.5.2 (see #10569)?

As for no longer accepting cookies, that is not an assumption but another
observation. Specifically, when I visit a site that I know uses cookies
(such as google) in TorBrowserBundle-3.5.2, and click on the Tor button
and select the cookie protections menu item, it would present me with a
dialog box that showed me the current list of cookies and there would be
cookies displayed there. However, when I do the same thing in
TorBrowserBundle-3.5.3, the cookie protections dialog box appears with the
part that displays the current list of cookies is always empty.

Well, alas, that does nothing say about available cookies. Rather, this is a known Mozilla bug, see: #10353. Cookies are not visible in the Private Browsing Mode at the moment. That's why I was asking.

In addition to that, whenever I try to log into a website that uses cookies
for logging in (e.g. ebay), it doesn't work. It just returns me to the
preceding page with the "sign in" links still present (which aren't there
when the user is signed in). That was the dead giveaway that made me look
at the cookie protections dialog in the first place.

But that can have a bunch of different issues (which is why #10569 was closed as it turned out to be an unrelated one). Btw: Logging into this bugtracker needs working cookies, too. So, the best thing to do is to file different bugs for each site not behaving as expected like I did with #11293 and #11294 and then to close this bug. Thanks!

comment:5 in reply to:  4 Changed 5 years ago by jake

Resolution: not a bug
Status: newclosed

Replying to gk:

Replying to jake:
Not sure what was wrong. Maybe you disabled the Private Browsing Mode due to login problesm with TBB 3.5.2 (see #10569)?

That must be what happened. Funny I don't remember ever seeing the dialog box
where that setting is. It just shows that you can't trust memory.

In addition to that, whenever I try to log into a website that uses cookies
for logging in (e.g. ebay), it doesn't work. It just returns me to the
preceding page with the "sign in" links still present (which aren't there
when the user is signed in). That was the dead giveaway that made me look
at the cookie protections dialog in the first place.

But that can have a bunch of different issues (which is why #10569 was closed as it turned out to be an unrelated one). Btw: Logging into this bugtracker needs working cookies, too. So, the best thing to do is to file different bugs for each site not behaving as expected like I did with #11293 and #11294 and then to close this bug. Thanks!

Will do, thanks.

More testing shows that logging to ebay.com.au works some times and not others.
I doubt that it warrants another report.

Note: See TracTickets for help on using tickets.