Opened 5 years ago

Last modified 21 months ago

#11311 new defect

httpse-ruleset-bug: wistia ruleset breaks some video thumbnail generation

Reported by: cypherpunks Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E 3.4.3
Severity: Normal Keywords: httpse-ruleset-bug
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

My HTTPS-E version is actually 3.4.5, but I didn't see that listed in the version field...

Problem url:
http://www.bitplane.com/learning

Click on "Advanced Search", and filter the list for "tutorial videos" or "webinar recordings" -> thumbnails of the flash videos (hosted by wistia) are generally not visible. If you choose "application video gallery" instead, those flash video thumbnails (also wistia-hosted) work fine.

I noticed one difference is that the videos with thumbnails that work are playing back in a floating overlay window, but the ones where thumbnails fail are playing back in a player that's embedded in the webpage.

The reason I submitted this as a ruleset bug for the wistia domains is that, if I disable the "Wistia (parial)" ruleset, all the video thumbnails are generated just fine.

Since Wistia sells video hosting services, I guess this may affect other customers of theirs besides bitplane.com, but I don't know of any other specific ones other than their "sister site":
http://www.andor.com/learning-academy?type=video
(Bitplane is an Andor / Oxford Instruments company)

Child Tickets

Change History (1)

comment:1 Changed 21 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

Note: See TracTickets for help on using tickets.