Opened 6 years ago

Closed 5 years ago

Last modified 3 years ago

#11315 closed defect (duplicate)

Invalid write of size 8

Reported by: arma Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay valgrind 025-triaged 025-deferrable
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

on moria1, running nickm/bug11278, on exit:

==27246== Invalid write of size 8
==27246==    at 0x52C8523: ??? (in /usr/lib/libevent-1.4.so.2.1.3)
==27246==    by 0x52C8875: event_del (in /usr/lib/libevent-1.4.so.2.1.3)
==27246==    by 0x517C08: tor_event_free (compat_libevent.c:151)
==27246==    by 0x517C30: periodic_timer_free (compat_libevent.c:573)
==27246==    by 0x42B080: tor_free_all (main.c:2554)
==27246==    by 0x42B0C3: tor_cleanup (main.c:2591)
==27246==    by 0x4F0CF2: hibernate_begin (hibernate.c:759)
==27246==    by 0x42DDC1: process_signal (main.c:2070)
==27246==    by 0x52C9343: event_base_loop (in /usr/lib/libevent-1.4.so.2.1.3)
==27246==    by 0x42C1A0: do_main_loop (main.c:2009)
==27246==    by 0x42CF24: tor_main (main.c:2882)
==27246==    by 0x5EFEC8C: (below main) (libc-start.c:228)
==27246==  Address 0xae358e0 is not stack'd, malloc'd or (recently) free'd

How odd.

Child Tickets

Change History (7)

comment:1 Changed 6 years ago by nickm

Keywords: tor-relay valgrind 025-triaged 025-deferrable added
Status: newneeds_information

we're not going to figure that one out unless libevent-1.4 debug symbols get installed. And it could just as easily be a libevent 1.4 bug -- there are lots of those, libevent 1.4 is old.

comment:2 Changed 6 years ago by arma

I got this again when moria1 exited, this time running git commit cd1517244 so it is not related to #11278.

comment:3 Changed 6 years ago by nickm

Are there any libevent debug symbols packages you haven't installed?

comment:4 Changed 6 years ago by nickm

Milestone: Tor: 0.2.5.x-finalTor: 0.2.???

Putting this in 0.2.???; they should get moved back into a more timed milestone once they're no longer in needs_information.

comment:5 Changed 5 years ago by nickm

Resolution: duplicate
Status: needs_informationclosed

This is a duplicate of #12985, which has a patch.

comment:6 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:7 Changed 3 years ago by nickm

Milestone: Tor: 0.3.???

Milestone deleted

Note: See TracTickets for help on using tickets.