Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11319 closed defect (not a bug)

TBB Automatically Chooses an Inappropriate Size for Its Main Window

Reported by: CRhode Owned by: mikeperry
Priority: Medium Milestone:
Component: TorBrowserButton Version:
Severity: Keywords: tbb-usability
Cc: CRhode@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

TBB opens with the bottom edge of its frame beyond the lower limit of the screen in Gnome3.

This is a follow-on to Bug #11078 and is motivated by a request for additional information there.

TBB attempts to choose window dimensions from a small set so any particular user is likely to fall into the same category with many others and therefore be less identifiable. It should pick a window size that fits completely within the screen size on the user's terminal. Here is a case where it doesn't.

When the User hovers the cursor over a link, Firefox shows a pop-up box (toaster) in the lower left containing the link's URL. In the attached screen shot, only the top few pixels of that toaster are visible.

Maximizing the TBB window brings it all back into view but impacts anonymity because Firefox reports the new window size in response to server inquiries. The full-screen window size may be more or less unique to the User.

Child Tickets

Attachments (1)

Screenshot from 2014-03-26 09:30:30.png (92.3 KB) - added by CRhode 5 years ago.
Screenshot of TBB Initial Window

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by CRhode

Screenshot of TBB Initial Window

comment:1 Changed 5 years ago by gk

Status: newneeds_information

What is the relation of this bug to #11078? They seem to be about different things or am I missing something? Does your window get correctly rounded to a multiple of 200x100, though? Do you have a taskbar that could play a role here (see the issues in #9268)?

comment:2 Changed 5 years ago by gk

Okay, scratch my first two questions :) (the other two remain)

comment:3 in reply to:  1 ; Changed 5 years ago by CRhode

Replying to gk:

Do you have a taskbar that could play a role here (see the issues in #9268)?

Ah, yes, ... and I haven't mentioned before that I do run the PrefBar extension ... so this looks like it's related to Bug #9268.

What is the relation of this bug to #11078? They seem to be about different things or am I missing something?

... completely (well ... not completely) different! My big hangup is still Bug #11078. I don't seem to be able to specify a long enough delay in Devilspie for TBB to quiesce and accept a resize maximize request. If TBB calculated the total space required, including all the toolbars, and kept the extremities of its main window within the confines of the physical screen, then I might learn to live with it and take it out from under Devilspie's control.

Last edited 5 years ago by CRhode (previous) (diff)

comment:4 Changed 5 years ago by CRhode

... and I know I'm not supposed to do that (run extensions like PrefBar), but I'm constantly fiddling with the four switches it gives me: Colors, Images, Font -, and Font +. I wish TBB did that.

comment:5 in reply to:  3 ; Changed 5 years ago by gk

Status: needs_informationnew

Replying to CRhode:

Replying to gk:

Do you have a taskbar that could play a role here (see the issues in #9268)?

Ah, yes, ... and I haven't mentioned before that I do run the PrefBar extension ... so this looks like it's related to Bug #9268.

Could you test that (i.e. disable the taskbar by default enabling it only when you hover over it with your mouse)? Maybe disabling this extension might shed some light on this problem, too...

comment:6 in reply to:  5 Changed 5 years ago by CRhode

Replying to gk:

Could you test that (i.e. disable the taskbar by default enabling it only when you hover over it with your mouse)? Maybe disabling this extension might shed some light on this problem, too...

Yes, window size is appropriate under these conditions:

PrefBar can be hidden/restored with <F8>.

I killed *devilspie*. I hid PrefBar. I selected TBB "New Identity." TBB went away and came back with a window slightly smaller that fit within the screen boundaries.

I restored PrefBar, but the window size remained the same as before.

Leaving PrefBar restored, I select TBB "New Identity" then, but, when TBB comes back, it's window is deeper by the height of the PrefBar, and the bottom edge of the screen obscures the bottom edge of its window.

comment:7 Changed 5 years ago by gk

Resolution: not a bug
Status: newclosed

Okay. Then there is not much we can do here. Other extensions can mess in a lot of ways with the fingerprinting defenses the Tor Browser has. I am not even sure if solving #9268 would help in this case.
Maybe solving #7256 might help? I'll make a note there and close this as "not a bug".

comment:8 Changed 5 years ago by gk

Version: Tor: unspecified

comment:9 in reply to:  7 ; Changed 5 years ago by CRhode

Replying to gk:

I am not even sure if solving #9268 would help in this case.

I repose great faith in fixing Bug #9268.

comment:10 in reply to:  9 Changed 5 years ago by gk

Replying to CRhode:

Replying to gk:

I am not even sure if solving #9268 would help in this case.

I repose great faith in fixing Bug #9268.

Could you test the latest extension attached there? I am curious whether the proposed solution works for you...

Note: See TracTickets for help on using tickets.