Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11353 closed defect (fixed)

i386 ooni deb package: unmet dependencies

Reported by: anadahz Owned by: hellais
Priority: Medium Milestone:
Component: Archived/Ooni Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Repository: deb.ooni.nu
Kernel: 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux

$ cat /etc/issue
Debian GNU/Linux 7 \n \l

$ cat /etc/*release
PRETTY_NAME="Debian GNU/Linux 7 (wheezy)"
NAME="Debian GNU/Linux"
VERSION_ID="7"
VERSION="7 (wheezy)"

$ apt-get install ooniprobe 
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ooniprobe : Depends: python-twisted (>= 12.2.0) but it is not going to be installed
             Depends: python-txsocksx but it is not going to be installed
             Depends: python-txtorcon (>= 0.7) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by hellais

Can you show me the content of your /etc/apt/sources.list.

Also what happens if you do:

aptitude show python-twisted

aptitude show ooniprobe

aptitude show python-txsocksx

?

comment:2 Changed 5 years ago by arma

Hellais, did we replace the ooni debs on deb.ooni.nu with the ones that Lunar submitted to Debian? Or are these still the older ones we had from January? (Seems like at some point we should unify them.)

comment:3 Changed 5 years ago by anadahz

Resolution: fixed
Status: newclosed

I can confirm the successful installation of ooniprobe package in both repositories deb.ooni.nu and Debian sid.

comment:4 Changed 5 years ago by hellais

Awesome! Thanks for letting us know :)

Note: See TracTickets for help on using tickets.