Opened 6 years ago

Closed 3 years ago

#11371 closed defect (user disappeared)

Tor Browser doesn't work on OSX 10.8.5 - Mountain Lion

Reported by: cypherpunks Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-3.5
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Interesting that an older Tor Browser works, but the latest one doesn't. Would you please open a new bug ticket on bugs.torproject.org describing the details of your experiment?

I am using OSX 10.8.5 - Mountain Lion (not Mavericks for performance reasons) with my OSX firewall on AND with Sophos antivirus 9.0.8. I do not want to relax these settings for security reasons.

I am successfully playing with Vidalia 0.2.21 & TOR 0.2.4.9-alpha (git-23dd7c901287d7d8) Qt 4.8.1 (TorBrowser-2.4.9-alpha-1-osx-i386-en-US.zip) -- which DOES work. This is the old version with separate Vidalia and the old Firefox browser.

However, when today I installed the CURRENT version of TOR (TorBrowserBundle-3.5.3-osx32_en-US.zip), it would not work. The TorButton onion turns green but I am not actually making any kind of network connection:

Here are the logs:

3/29/14 19:26:05.157 [NOTICE] Opening Socks listener on 127.0.0.1:9150
3/29/14 19:26:05.157 [NOTICE] Renaming old configuration file to "/Applications/Privacy/TorBrowserBundle_en-US.app/Data/Tor/torrc.orig.1"
3/29/14 19:26:05.490 [NOTICE] Bootstrapped 5%: Connecting to directory server.
3/29/14 19:26:05.490 [NOTICE] Bootstrapped 10%: Finishing handshake with directory server.
3/29/14 19:26:05.621 [NOTICE] Bootstrapped 15%: Establishing an encrypted directory connection.
3/29/14 19:26:05.741 [NOTICE] Bootstrapped 20%: Asking for networkstatus consensus.
3/29/14 19:26:05.790 [NOTICE] Bootstrapped 25%: Loading networkstatus consensus.
3/29/14 19:26:06.306 [NOTICE] I learned some more directory information, but not enough to build a circuit: We have no usable consensus.
3/29/14 19:26:07.110 [NOTICE] Bootstrapped 40%: Loading authority key certs.
3/29/14 19:26:07.587 [NOTICE] Bootstrapped 45%: Asking for relay descriptors.
3/29/14 19:26:07.588 [NOTICE] I learned some more directory information, but not enough to build a circuit: We need more microdescriptors: we have 0/5570, and can only build 0% of likely paths. (We have 0% of guards bw, 0% of midpoint bw, and 0% of exit bw.)
3/29/14 19:26:08.655 [NOTICE] Bootstrapped 50%: Loading relay descriptors.
3/29/14 19:26:09.320 [NOTICE] Bootstrapped 51%: Loading relay descriptors.
3/29/14 19:26:09.155 [NOTICE] Bootstrapped 53%: Loading relay descriptors.
3/29/14 19:26:09.269 [NOTICE] Bootstrapped 55%: Loading relay descriptors.
3/29/14 19:26:09.332 [NOTICE] Bootstrapped 57%: Loading relay descriptors.
3/29/14 19:26:09.332 [NOTICE] Bootstrapped 59%: Loading relay descriptors.
3/29/14 19:26:09.388 [NOTICE] Bootstrapped 61%: Loading relay descriptors.
3/29/14 19:26:09.443 [NOTICE] Bootstrapped 63%: Loading relay descriptors.
3/29/14 19:26:09.444 [NOTICE] Bootstrapped 65%: Loading relay descriptors.
3/29/14 19:26:09.504 [NOTICE] Bootstrapped 67%: Loading relay descriptors.
3/29/14 19:26:09.546 [NOTICE] Bootstrapped 68%: Loading relay descriptors.
3/29/14 19:26:09.546 [NOTICE] Bootstrapped 70%: Loading relay descriptors.
3/29/14 19:26:09.560 [NOTICE] Bootstrapped 72%: Loading relay descriptors.
3/29/14 19:26:09.593 [NOTICE] Bootstrapped 74%: Loading relay descriptors.
3/29/14 19:26:09.620 [NOTICE] Bootstrapped 76%: Loading relay descriptors.
3/29/14 19:26:09.653 [NOTICE] Bootstrapped 78%: Loading relay descriptors.
3/29/14 19:26:36.449 [NOTICE] We now have enough directory information to build circuits.
3/29/14 19:26:36.449 [NOTICE] Bootstrapped 80%: Connecting to the Tor network.
3/29/14 19:26:36.449 [NOTICE] Bootstrapped 90%: Establishing a Tor circuit.
3/29/14 19:26:39.255 [NOTICE] Tor has successfully opened a circuit. Looks like client functionality is working.
3/29/14 19:26:39.255 [NOTICE] Bootstrapped 100%: Done.
3/29/14 19:26:40.988 [NOTICE] New control connection opened.
3/29/14 19:28:40.438 [NOTICE] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)
3/29/14 19:28:43.435 [NOTICE] Tried for 120 seconds to get a connection to [scrubbed]:0. Giving up. (waiting for socks info)

Child Tickets

Change History (5)

comment:1 Changed 6 years ago by gk

Component: TorbuttonTor bundles/installation
Keywords: tbb-3.5 added
Milestone: Tor: unspecified
Owner: set to erinn
Priority: criticalnormal
Version: Tor: unspecified

Does https://www.torproject.org/docs/faq#SophosOnMac help? What does happen if you disable/get rid of your Sophos program only for testing purposes? Does this fix your issue?

comment:2 in reply to:  1 Changed 6 years ago by arma

Replying to gk:

Does https://www.torproject.org/docs/faq#SophosOnMac help?

This person's Tor is pretty clearly "getting to the Internet" -- it bootstraps. But the next thing that sophos might be doing is preventing Tor Browser's connections from reaching Tor's local socket. So yes, this is still a fine question.

comment:3 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:4 Changed 5 years ago by cypherpunks

Status: newneeds_information

comment:5 Changed 3 years ago by bugzilla

Component: Applications/Tor bundles/installationApplications/Tor Browser
Keywords: needs-triage removed
Resolution: user disappeared
Severity: Normal
Status: needs_informationclosed
Summary: New TOR not working on Mountain LionTor Browser doesn't work on OSX 10.8.5 - Mountain Lion
Note: See TracTickets for help on using tickets.