Opened 5 years ago

Closed 4 years ago

#11432 closed enhancement (duplicate)

Start a bridge's uptime history when it was first listed in a status

Reported by: karsten Owned by: karsten
Priority: Low Milestone:
Component: Metrics/Onionoo Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We're currently starting a relay's or bridge's uptime history when it was first listed in a network status with the Running flag. We do this to avoid displaying an uptime of 0% when the relay or bridge didn't even exist.

Turns out there are edge cases of bridges who are listed in the network status but without the Running flag. Those bridges should be displayed with an uptime of 0%.

We need to store an additional data point for these bridges: when they were first listed in a status. Our current data format doesn't support this, because we only store when a relay or bridge was listed as running.

We'll want to have this feature for relays, too, because we're going to parse votes at some point, and then we may have relays that are contained in some or even all votes, but with too few Running flags to also make it into the consensus.

Child Tickets

Change History (1)

comment:1 Changed 4 years ago by karsten

Resolution: duplicate
Status: newclosed

This is going to be implemented/obsolete with #15177. Going through the description:

We're currently starting a relay's or bridge's uptime history when it was first listed in a network status with the Running flag. We do this to avoid displaying an uptime of 0% when the relay or bridge didn't even exist.

With #15177, we also add a relay or bridge to our uptime history if it's contained in a status without any flag, that is, even if it doesn't have the Running flag.

Turns out there are edge cases of bridges who are listed in the network status but without the Running flag. Those bridges should be displayed with an uptime of 0%.

These edge cases do exist, but we shouldn't display an uptime of 0% only because the bridge authority couldn't reach the bridge. The bridge authority only tests reachability of a bridge's OR port, but an increasing number of bridges support one or more pluggable transports on different ports which the bridge authority doesn't test. The Running flag is not as important anymore as a few years back. These bridges should be displayed with an uptime of 100% if they are listed in the status, regardless of with or without the Running flag.

We need to store an additional data point for these bridges: when they were first listed in a status. Our current data format doesn't support this, because we only store when a relay or bridge was listed as running.

This implementation suggestion is now obsolete.

We'll want to have this feature for relays, too, because we're going to parse votes at some point, and then we may have relays that are contained in some or even all votes, but with too few Running flags to also make it into the consensus.

It's unclear if we really want to include relays in the uptime history that did not make it into the consensus.

All in all, I'm closing this ticket. The summary "Start a bridge's uptime history when it was first listed in a status" is implemented with #15177. Resolving as near duplicate of #15177.

Note: See TracTickets for help on using tickets.