Opened 5 years ago

Closed 4 years ago

#11449 closed defect (fixed)

Torbutton New Identity error with regard to NoScript

Reported by: Cypherpunks Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Keywords: tbb-newnym, tbb-usability, tbb-torbutton, MikePerry201410R
Cc: Tize, loic, Diapolo Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Error reads:

Torbutton: Error clearing NoScript Temporary Permissions: TypeError: Components.classes@maone.net/noscript-service;1 is undefined

I'll be monitoring this bug to give feedback as needed.

I think I'm running 3.6 but I might be running the latest PT bundle. Hard to tell! Filing another bug about that :/

Thanks!

Child Tickets

Change History (13)

comment:1 Changed 5 years ago by gk

Component: TorbuttonTorBrowserButton
Keywords: tbb-newnym added; NoScript Torbutton Error Permissions removed
Owner: set to mikeperry
Version: Tor: unspecified

Works for me. Does that problem persist if you donwload a clean, new version? If so, which version is affected? Does it happen regularly? Do you have special NoScript settings or are you using the default ones? Re: your version, see my comment in #11450.

comment:2 Changed 5 years ago by Cypherpunks

As per #11450, version is 3.6-beta-1-Windows.

As far as I remember, NoScript was last installed fresh, then disabled (but not uninstalled), and certainly it has been disabled for a long time. It is not enabled and was not when I first got the error (I use a different toggle that blocks all java, I don't like NoScript).

I tend to install on top of previous installs. I know this can lead to bugs (peripheral issue: if advice is available regarding how to update clean without having to reinstall all plugins and re-set all settings, it would be appreciated)

I'll post again when I've run a fresh instance with NoScript disabled.

comment:3 Changed 5 years ago by Cypherpunks

Unpacked fresh instance to new random location, ran it, went into addons, disabled NoScript, hit restart, when browser reappeared hit New Identity, same error.

Did not install any addons or plugins or alter any settings other than to disable NoScript.

For what it's worth, I use QuickJS instead as per: https://trac.torproject.org/projects/tor/wiki/doc/TorBrowserBundle3FAQ.

comment:4 Changed 5 years ago by gk

The problem is disabling NoScript as we are currently using a part of its code to clear temporary NoScript permissions. We should be smarter here and check whether NoScript is enabled at all (and only show the alert in this case!? or not calling eraseTemp() in the first place?). If it is disabled then there should not be any temporary NoScript permission active, and hence no need to clear the perms/show the alert.

comment:5 Changed 5 years ago by gk

Keywords: tbb-usability added

comment:6 Changed 5 years ago by gk

Cc: Tize added

comment:7 Changed 5 years ago by erinn

Component: TorBrowserButtonTor Browser
Keywords: tbb-torbutton added
Owner: changed from mikeperry to tbb-team

comment:8 Changed 5 years ago by loic

Cc: loic added
Status: newneeds_review

comment:9 Changed 5 years ago by mcs

Keywords: MikePerry201410R added

Thanks for the patch. It looks good to me.

Did you test it with NoScript enabled and disabled?

I added MikePerry201410R so Mike will review and merge (assuming it looks OK to him).

comment:10 Changed 5 years ago by loic

I did, I added an alert before and inside the if. The first one gets called always (with NoScript enabled and disabled), the second one only if NoScript is enabled.

comment:11 Changed 4 years ago by gk

#13943 is a duplicate. I just see we had a reviewed patch? Seems this fell through the cracks.

mcs: You reviewed it. As review power = merge power go ahead. :) Otherwise I'll take care of it tomorrow.

comment:12 Changed 4 years ago by gk

Cc: Diapolo added

comment:13 Changed 4 years ago by mcs

Resolution: fixed
Status: needs_reviewclosed

Fixed by 88dfaaaf325f5b86aba3d449b87320d0d962681d. Thanks again for the patch.

Note: See TracTickets for help on using tickets.