Opened 5 years ago

Closed 2 years ago

#11459 closed defect (fixed)

libfaketime causes the build system to report being not sane

Reported by: gk Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-gitian
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

libfaketime causes build systems to report that they are not sane which can easily lead to an endless loop or at least to a much longer build time. This is only an issue if more than one core is used for building the TBBs.

Child Tickets

Change History (6)

comment:1 Changed 5 years ago by gk

GMP is one example which was already mentioned in #9711 comment 6:

 /bin/bash ./config.status
config.status: creating demos/pexpr-config.h
config.status: creating demos/calc/calc-config.h
config.status: creating Makefile
config.status: creating mpf/Makefile
config.status: creating mpn/Makefile
config.status: creating mpq/Makefile
config.status: creating mpz/Makefile
config.status: creating printf/Makefile
config.status: creating scanf/Makefile
config.status: creating rand/Makefile
config.status: creating cxx/Makefile
config.status: creating tests/Makefile
config.status: creating tests/devel/Makefile
config.status: creating tests/mpf/Makefile
config.status: creating tests/mpn/Makefile
config.status: creating tests/mpq/Makefile
config.status: creating tests/mpz/Makefile
config.status: creating tests/rand/Makefile
config.status: creating tests/misc/Makefile
config.status: creating tests/cxx/Makefile
config.status: creating doc/Makefile
config.status: creating tune/Makefile
config.status: creating demos/Makefile
config.status: creating demos/calc/Makefile
config.status: creating demos/expr/Makefile
config.status: creating gmp.h
config.status: creating config.h
config.status: config.h is unchanged

snip

config.status: executing libtool commands
make[1]: Leaving directory `/home/ubuntu/build/gmp-5.1.3'
make[1]: Entering directory `/home/ubuntu/build/gmp-5.1.3'
make[1]: Warning: File `Makefile' has modification time 0.72 s in the future

comment:2 Changed 5 years ago by gk

This can happen with libevent as well:

make: Warning: File `.deps/win32select.Plo' has modification time 0.21 s in the future
 /bin/bash ./config.status
config.status: creating libevent.pc
config.status: creating libevent_openssl.pc
config.status: creating libevent_pthreads.pc
config.status: creating Makefile
config.status: creating include/Makefile
config.status: creating test/Makefile
config.status: creating sample/Makefile
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing depfiles commands
config.status: executing libtool commands
make: Warning: File `.deps/win32select.Plo' has modification time 0.17 s in the future

Note: Mike's idea in #9829 comment 82 might be something to think about.

comment:3 Changed 5 years ago by gk

Update:
1) This is not only an issue if more than one core is used. Using one core just makes it more likely that the build is not failing.
2) The issue is not (only) a build taking more time but rather it can still fail directly due to the bug. See: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=61314 as an example where we can't build GCC 4.9.0 with libfaketime enabled.

comment:4 Changed 5 years ago by erinn

Component: Tor bundles/installationTor Browser
Keywords: tbb-gitian added
Owner: changed from erinn to tbb-team

comment:5 Changed 5 years ago by gk

See comment:12:ticket:12461 for a possible remedy.

comment:6 Changed 2 years ago by gk

Keywords: gitian removed
Resolution: fixed
Severity: Normal
Status: newclosed

No such things happen anymore, so we fixed all the issues as far as I can tell.

Note: See TracTickets for help on using tickets.