Opened 5 years ago

Closed 5 years ago

#11468 closed defect (not a bug)

tor launcher

Reported by: bitcoin.bcn Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm running a debian 64bit wheezy kde.
When run start-tor-broswer appear "Tor unexpectedly exited." It happens since this version. with older don't happens! I try in many users sesion and try "killall tor", restart and nothing. I tryed delate, and donwload again. Also with check user owner.
Also I can execute older tor!

What can I do???

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by gk

You could start Tor Browser from the terminal with

./start-tor-browser

and attach the log output to this bug. It's hopefully explaining what is going on.

comment:2 Changed 5 years ago by bitcoin.bcn

OKis! thanks for answer.

I ran./start-tor-browser

#:~/Recursos/tor$ ./start-tor-browser

Launching Tor Browser Bundle for Linux in /home/garcia/Recursos/tor
Apr 12 14:25:56.746 [notice] Tor v0.2.4.21 (git-f5def645adfb32be) running on Linux with Libevent 2.0.21-stable and OpenSSL 1.0.1f.
Apr 12 14:25:56.747 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Apr 12 14:25:56.749 [notice] Read configuration file "/home/garcia/Recursos/tor/Data/Tor/torrc-defaults".
Apr 12 14:25:56.749 [notice] Read configuration file "/home/garcia/Recursos/tor/Data/Tor/torrc".
Apr 12 14:25:56.773 [notice] Opening Control listener on 127.0.0.1:9051
Apr 12 14:25:56.773 [warn] Could not bind to 127.0.0.1:9051: Cannot assign requested address
Apr 12 14:25:56.773 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Apr 12 14:25:56.773 [err] Reading config failed--see warnings above

comment:3 Changed 5 years ago by gk

Milestone: Tor: unspecified
Resolution: not a bug
Status: newclosed

Hmmm... seems some process is already listening on port 9051. Maybe an other instance of tor started via the Tor Browser? Anyway, this is not a bug. You might want to ask the support for further help in case you can't solve this issue alone (see: https://www.torproject.org/about/contact.html.en#support).

Note: See TracTickets for help on using tickets.