Opened 10 years ago

Last modified 10 years ago

#1151 closed defect (Fixed)

Tor bundle fail to build on linux 64 bits

Reported by: stars Owned by:
Priority: Low Milestone:
Component: Applications/Tor bundles/installation Version: 0.2.1.20
Severity: Keywords:
Cc: stars, nickm, Sebastian, arma, erinn Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello,

I run ubunru karmic 9.10 on x86 64 , version 64 bits.

I have the last svn version:URL : https://tor-svn.freehaven.net/svn/torbrowser/trunk/build-scripts
Racine du dépôt : https://tor-svn.freehaven.net/svn
UUID du dépôt : 55e972cd-5a19-0410-ae62-a4d7a52db4cd
Révision : 20956
Type de nœud : répertoire
Tâche programmée : normale
Auteur de la dernière modification : phobos
Révision de la dernière modification : 20956
Date de la dernière modification: 2009-11-16 12:27:23 +0100 (lun 16 nov 2009)

2.6.31-15-generic #50-Ubuntu SMP Tue Nov 10 14:53:52 UTC 2009 x86_64 GNU/Linux

I have this 2 errors on build:

/usr/bin/ld: /tmp/buildbuiltliblibssl.a(s2_srvr.o): relocation R_X86_64_32 against `.data' can not be used when making a shared object; recompile with -fPIC
/tmp/build
builtliblibssl.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[2]: * lib/libQtNetwork.so.4.5.3 Erreur 1
make[2]: quittant le répertoire « /tmp/build/qt-x11-opensource-src-4.5.3/src/network »
make[1]:
* [sub-network-make_default-ordered] Erreur 2
make[1]: quittant le répertoire « /tmp/build/qt-x11-opensource-src-4.5.3 »
make: * [build-qt] Erreur 2

real 21m4.949s
user 2m4.880s
sys 2m39.200s

I have edited "make.linux" and "make" to use openssl-0.9.8k instead "l" but make no difference

Best regards

SwissToeExit

[Automatically added by flyspray2trac: Operating System: Other Linux]

Child Tickets

Change History (5)

comment:1 Changed 10 years ago by nickm

It looks like the error part is

"relocation R_X86_64_32 against `.data' can not be used when making a shared object; recompile with -fPIC"

but I'm not sure the best fix. Googling for that error suggests that making sure your libtool is recent might help,
or you might need to rebuild libssl (or maybe Qt) with the -fPIC flag passed to the C compiler.

comment:2 Changed 10 years ago by arma

Erinn, is the new TBB Linux build process sufficiently different from the one
in November that we should close (and ignore) this bug? Or can you still learn
something useful from it?

comment:3 Changed 10 years ago by stars

Hello,

I have not become the answer, i will retry with last version and give my feedback

Best Regards

comment:4 Changed 10 years ago by erinn

The solution for this is to rebuild openssl with 'shared'. In Makefile.linux that'd be:

OPENSSL_OPTS=-no-idea -no-rc5 -no-md2 shared zlib --prefix=$(BUILT_DIR) --openssldir=$(BUILT_DIR) -I$(BUILT_DIR)/lib/

I've fixed it in torbrowser's trunk too.

comment:5 Changed 10 years ago by erinn

flyspray2trac: bug closed.
fixed in torbrowser rev 22000 in svn

Note: See TracTickets for help on using tickets.