Opened 6 years ago

Closed 6 years ago

#11530 closed defect (fixed)

HTTPS Everywhere 3.5 (FF 28) freezes browser when clicking javascript links

Reported by: cypherpunks Owned by: pde
Priority: High Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Pages that have linking using javascript: links cause the browser to lock up when you click on one of them. Most of the examples I have are internal or private logins, but I did see it on http://www.talkshoe.com/talkshoe/web/talkNow.jsp?pushNav=1&cmd=live when attempting to click on any of the Join In buttons.

Child Tickets

Change History (7)

comment:1 Changed 6 years ago by cypherpunks

Priority: normalmajor

comment:2 Changed 6 years ago by zyan

Status: newneeds_information

Hm, I tried clicking on the "Join Now" links in the example you gave and couldn't repro this bug with HTTPS E 3.5 in FF24 or FF28. Any other examples?

comment:3 Changed 6 years ago by zyan

May be related to the Doubleclick rule. Can you try turning it off if it's being applied?

comment:4 Changed 6 years ago by zyan

Resolution: fixed
Status: needs_informationclosed

comment:5 Changed 6 years ago by zyan

Resolution: fixed
Status: closedreopened

Oops, turns out that wasn't OP but another person with a similar problem on IRC. Reopening for now.

comment:6 Changed 6 years ago by cypherpunks

I'm OP and I can confirm with 3.5.1 that the problem is now fixed. Sorry I didn't see this sooner or I would have tried the Doubleclick option, but I'm pretty sure one of the pages I use did not have anything from them, but it is now working and not freezing up.

Sorry I didn't have more examples. Most of them seemed to be private login pages, so they'd be no easy way to verify with others.

This ticket can now be closed.

comment:7 Changed 6 years ago by zyan

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.