Opened 5 years ago

Closed 5 years ago

#11540 closed defect (fixed)

Firefox freezes on enabling JS on specific sites

Reported by: cypherpunks Owned by: pde
Priority: Immediate Milestone: HTTPS-E 3.5
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: trac@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When trying to open one of the login pages of my bank, https://ekort.swedbank.se/ in Firefox 24.4.0 ESR and newly-updated HTTPS-everywhere 3.5, the page loads with HTTPS-everywhere enabled, but when I add an exception in NoScript to allow JS on the page and reload it, the browser windows freezes permanently. Disabling all plugins except HTTPS-everywhere makes no difference, neither does re-installing the plugin. However, trying on another install with the exact same version of Firefox but a more or less untouched user profile and HTTPS-everywhere the page loads without freezing. This might be related to bug #11530 - which I can also reproduce.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by zyan

Status: newneeds_information

Strange, I couldn't repro this on either FF28 or FF ESR 24.4. I don't see an HTTPS Everywhere rule for the page either. (I also can't repro #11530)

However, trying on another install with the exact same version of Firefox but a more or less untouched user profile and HTTPS-everywhere the page loads without freezing.

Does that mean the page does work with HTTPS Everywhere on a clean profile?

Could this be a problem with Flash?

comment:2 Changed 5 years ago by cypherpunks

Managed to find the likely culprit, the DoubleClick opt-out plugin(https://www.google.com/settings/ads/plugin). For some reason I forgot to include it while testing before - with this plugin disabled/removed it works with both existing and new profiles.

This also makes me unable to reproduce #11530.

I'm not really sure why this is a problem with this specific bank web site, and why it only happens with HTTPS-Everywhere enabled, however.

comment:3 Changed 5 years ago by zyan

Resolution: fixed
Status: needs_informationclosed

Aha! I think this may be due to the fact that we shipped an on-by-default Doubleclick rule in the last release. If you see Doubleclick applied to the bank's page, try turning the rule off.

Note: See TracTickets for help on using tickets.