Opened 6 years ago

Closed 6 years ago

#11543 closed defect (fixed)

Clarify libseccomp "platform not supported" warning.

Reported by: nickm Owned by:
Priority: Medium Milestone: Tor: 0.2.5.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client sandbox ui easy
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Here's an unhelpful thing: "Sandboxing is not implemented for your platform. The feature is currently disabled".

Probably better to distinguish whether sandboxing would work if we had a different kernel (old linux), or if we had libseccomp (new linux, built without libseccomp), or not at all (freebsd etc).

Child Tickets

Change History (1)

comment:1 Changed 6 years ago by nickm

Resolution: fixed
Status: newclosed

Fixed in b8fe8ee7486f43b33ccd5cfad99a5e87a7d246f6.

Note: See TracTickets for help on using tickets.