Opened 6 years ago

Closed 6 years ago

#11576 closed defect (duplicate)

Atlas shows "uptime" when it means "downtime"

Reported by: massar Owned by: phw
Priority: Medium Milestone:
Component: Metrics/Relay Search Version:
Severity: Keywords: atlas downtime uptime
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

There are quite a few nodes now with an old and new fingerprint and likely retaining their names, it is confusing though to see which one is 'up' or 'down' and thus which one is the active one when searching on name of them, as the "uptime" column shows "downtime" as "uptime".

Fix:
https://github.com/massar/atlas/commit/d976a5b530c24de8270f90d0ac76abddfb8dfcc8

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by karsten

Status: newneeds_revision

Non-running relays will only be displayed by Atlas until they are offline one week. Then things will magically be less confusing again, and only the running relays will be listed.

So, you're calculating downtime as time since last restarted? That's not correct. A relay or bridge may have been last restarted months ago and then been running for weeks; downtime is the time since it was last seen as running.

Unfortunately, that information is not yet available, but just the time when a relay or bridge was last seen, regardless of the Running flag. See #11430 for more details.

I think this is a duplicate of #9814. I suggest closing this ticket and writing a patch for that other ticket -- either one that doesn't display anything for non-running relays, or one that uses whatever comes out of #11430.

Thanks for working on making Atlas better!

comment:2 Changed 6 years ago by phw

Resolution: duplicate
Status: needs_revisionclosed

I agree with karsten that this problem is very similar to #9814. We might be able to reuse (parts of) massar's patch there. Either way, thanks for reporting this!

Note: See TracTickets for help on using tickets.