Opened 6 years ago

Closed 6 years ago

#11587 closed defect (duplicate)

Tor Browser launch_warning on file download

Reported by: cypherpunks Owned by: mikeperry
Priority: Medium Milestone:
Component: TorBrowserButton Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Platform:
Tor Browser Bundle 3.5.4

Steps to reproduce:

  1. Right click link to file (as pdf) that has usually the external application configured. (Did not try other filetype. maybe registered application is non relevent?)
  1. Click menu item to save the link onto your disk.

Expected behavior:

File download dialog

Actual behavior:

The modal dialog like this (english via <chrome/locale/[mylang]/torbutton.properties>):

<blockquote>
torbutton.popup.external.title = Load external content?

torbutton.popup.external.app = An external application is needed to handle:\n\n

torbutton.popup.external.note = \n\nNOTE: External applications are NOT Tor safe by default and can unmask you!\n

torbutton.popup.external.suggest = \nIf this file is untrusted, you should either save it to view while offline or in a VM,\nor consider using a transparent Tor proxy like Tails LiveCD or torsocks.\n

torbutton.popup.launch = Launch application

torbutton.popup.cancel = Cancel
</blockquote>

Frustrating. will the 'Launch application' button do download file, or launch application? did not try this, for the reasons warned by the dialog!!

Workaround:
Change extensions.torbutton.launch_warning = false

...then immed. change back. if the real app launch need to be stop?

(changing firefix pref to always download for the file type is NOT solving problem.)

Child Tickets

Change History (1)

comment:1 Changed 6 years ago by gk

Resolution: duplicate
Status: newclosed

Duplicate of #1079.

Note: See TracTickets for help on using tickets.