Opened 6 years ago

Closed 2 years ago

#11588 closed defect (fixed)

Amazon Web Services rule breaks product info videos on Amazon.com

Reported by: cypherpunks Owned by: pde
Priority: High Milestone: HTTPS-E next Chrome release
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Normal Keywords: amazon
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On pages like https://www.amazon.com/Conair-GMT900-iStubble-Facial-Trimmer/dp/B004PXIR1W, the only way the product video can be played is if encrypted connections to "Amazon Web Services" are not forced.

Chrome 34.0.1847.116
HTTPS Everywhere 2014.4.16

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by jsha

Status: newneeds_revision

Verified on Chrome with master. Does not reproduce on Firefox with master.

comment:2 Changed 5 years ago by cypherpunks

Adding a comment since I imagine this is related but not worth its own ticket:

Amazon Wishlist editing javascript controls (renaming list, deleting or moving items) are broken when the "Amazon Web Services" rule is enabled. Disabling the rule resolves the issues.

comment:3 Changed 2 years ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:4 Changed 2 years ago by cypherpunks

Resolution: fixed
Status: needs_revisionclosed

Video on provided test url now works with HTTPS Everywhere.

Note: See TracTickets for help on using tickets.