Opened 5 years ago

Closed 5 years ago

#11603 closed defect (duplicate)

Tor DNS resolver returns A record for AAAA query

Reported by: mickeyc Owned by:
Priority: Medium Milestone: Tor: 0.2.5.x-final
Component: Core Tor/Tor Version: Tor: 0.2.5.4-alpha
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

My normal system resolver:

mike@glue:~$ dig +short aaaa gmail.com @localhost
2a00:1450:4009:803::1015
mike@glue:~$

The Tor DNS resolver running on port 5304:

mike@glue:~$ dig +short aaaa gmail.com @localhost -p 5304
173.194.65.18
mike@glue:~$

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by nickm

Milestone: Tor: 0.2.5.x-final
Resolution: duplicate
Status: newclosed

This is probably a duplicate of 46a3914079d6aa91ef456 ; should be fixed by 46a3914079d6aa91ef456b4bb82d9f842feb0976 which will be in 0.2.5.4-alpha. Please reopen if 0.2.5.4-alpha doesn't solve the isssue.

comment:2 Changed 5 years ago by mickeyc

Resolution: duplicate
Status: closedreopened

Behaviour has changed with 0.2.5.4, but it is still broken. Now I'm getting an NXDOMAIN instead whenever I do any AAAA lookups. A record lookups are still fine:

mike@glue:~$ dig aaaa gmail.com @localhost -p 5304

; <<>> DiG 9.9.5-3-Debian <<>> aaaa gmail.com @localhost -p 5304
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 19056
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;gmail.com. IN AAAA

;; Query time: 249 msec
;; SERVER: ::1#5304(::1)
;; WHEN: Sun Apr 27 11:37:35 BST 2014
;; MSG SIZE rcvd: 27

mike@glue:~$ dig +short a gmail.com @localhost -p 5304
173.194.70.18
mike@glue:~$

comment:3 Changed 5 years ago by mickeyc

Version: Tor: 0.2.5.3-alphaTor: 0.2.5.4-alpha

comment:4 Changed 5 years ago by nickm

Resolution: duplicate
Status: reopenedclosed

I've created a new ticket for this new issues as #11625 ; it gets confusing when bug tickets start out by referring to one bug and later change their meaning so they're talking about another bug. The original report is definitely a duplicate of #10468.

Note: See TracTickets for help on using tickets.