Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#11605 closed defect (fixed)

Tor doesn't compile with --with-dmalloc

Reported by: alphawolf Owned by:
Priority: Medium Milestone: Tor: 0.2.5.x-final
Component: Core Tor/Tor Version: Tor: 0.2.5.3-alpha
Severity: Keywords: dmalloc
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

System is Debian Jessie w/ libdmalloc-dev 5.5.2-6. Tor version should actually be 0.2.5.4-alpha, but was not an option in the select box.

After ./configure --with-dmalloc, tor will not compile:

user@dev:~/Projects/tpo/tor$ make
make  all-am
make[1]: Entering directory `/home/user/Projects/tpo/tor'
  CC       src/common/util.o
In file included from src/common/util.h:16:0,
                 from src/common/util.c:21:
src/common/compat.h:350:22: error: expected declaration specifiers or ‘...’ before ‘(’ token
 #define SHORT_FILE__ (__FILE__)
                      ^
src/common/util.h:66:24: note: in expansion of macro ‘SHORT_FILE__’
 #define DMALLOC_ARGS , SHORT_FILE__, __LINE__
                        ^
src/common/util.h:122:65: note: in expansion of macro ‘DMALLOC_ARGS’
 #define tor_memdup_nulterm(s, n)       tor_memdup_nulterm_(s, n DMALLOC_ARGS)
                                                                 ^
src/common/util.c:306:1: note: in expansion of macro ‘tor_memdup_nulterm’
 tor_memdup_nulterm(const void *mem, size_t len DMALLOC_PARAMS)
 ^
src/common/util.c:306:1: error: expected declaration specifiers or ‘...’ before numeric constant
make[1]: *** [src/common/util.o] Error 1
make[1]: Leaving directory `/home/user/Projects/tpo/tor'
make: *** [all] Error 2

Child Tickets

Change History (4)

comment:1 Changed 5 years ago by nickm

Looks like an easy fix; see branch "bug11605_024" in my public repo. It's based on 0.2.4. (Are there more bugs to fix, or does dalloc work when that's merged in?)

On the other hand, it's been like that since 0.2.4.10-alpha and nobody reported it till today. Should we instead perhaps deprecate dmalloc?

comment:2 Changed 5 years ago by alphawolf

Tested and confirmed fixed against both 0.2.4.10-alpha and 0.2.5.4-alpha. No additional bugs with --with-dmalloc noted.

I'll leave it to the core to discuss whether it should be deprecated; my interest was purely curiosity.

comment:3 Changed 5 years ago by nickm

Resolution: fixed
Status: newclosed

Merged to 0.2.5; kicking the decision of whether we ever want dmalloc again down the road.

comment:4 Changed 5 years ago by nickm

(I say "no backport to 0.2.4" and arma concurs)

Note: See TracTickets for help on using tickets.