Opened 5 years ago

Closed 5 years ago

#11658 closed defect (fixed)

Unable to set the proxy in TBB 3.6

Reported by: sukhbir Owned by: brade
Priority: High Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-helpdesk-frequent, tbb-testcase
Cc: gk, mikeperry, mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am using the Tor Browser Bundle for Linux (x86_64) version 3.6. Trying to connect while using the SOCKS5 proxy, I get this error:

30/04/14 12:28:18.186 [WARN] Controller gave us config lines that didn't validate: You have configured more than one proxy type. (Socks4Proxy|Socks5Proxy|HTTPSProxy|ClientTransportPlugin) 
30/04/14 12:29:24.236 [WARN] Controller gave us config lines that didn't validate: You have configured more than one proxy type. (Socks4Proxy|Socks5Proxy|HTTPSProxy|ClientTransportPlugin) 
30/04/14 12:29:41.730 [WARN] Controller gave us config lines that didn't validate: You have configured more than one proxy type. (Socks4Proxy|Socks5Proxy|HTTPSProxy|ClientTransportPlugin) 

The steps are:

Does this computer need to use a proxy to access?
Yes

(Configure the SOCKS5 settings)
Does this computer's Internet connection go through a firewall that only allows connections ...?
No
Does your ISP block or censor connections to Tor?
No

Pressing Connect gives me this error.

Child Tickets

Change History (6)

comment:1 Changed 5 years ago by sukhbir

Component: Tor bundles/installationTor Launcher
Owner: changed from erinn to brade

comment:2 Changed 5 years ago by mttp

Summary: Unable to set the SOCKS proxy in TBB 3.6Unable to set the proxy in TBB 3.6

This applies not only to SOCKS proxies but HTTP proxies as well.

Nick's IRC comments seem relevant:

10:11 < nickm> GeKo: Does 3.6 provide a bunch of ClientTransportPlugin lines by default, and rely on the backported #5018 fix to launch the right ones?
10:11 -zwiebelbot:#tor-dev- [tor#5018: don't start ClientTransportPlugin proxies until we have a bridge that wants them]
10:11 < GeKo> nickm: yes.
10:11 < nickm> GeKo: I ask because it seems that warning will occur when you have any proxy set alongside ClientTransportPlugin.
10:11 < nickm> whether the plugins are launched or not
10:12 < nickm> [in Tor: src/or/config.c, grep for "You have configured more than one proxy type"]
10:13 < GeKo> pointing at 5018 would have been my first guess. I am just wondering why that should have broken things...
10:15 < GeKo> hmm...
10:15 < nickm> there's no problem in the 5018 code here...
10:15 < nickm> it just didn't go far enough
10:15 < nickm> 5018 let you set a bunch of ClientTransportPlugins that you did not set before.
10:16 < nickm> But there was this pre-existing check stopped proxies from being set at the same time as clienttransportplugin.
10:17 < GeKo> I see.
10:18 < nickm> There's a "make proxies work with client PTs" ticket in 0.2.6.x, I think
10:19 < nickm> perhaps as an interim thing you might want to not add all those clienttransportplugins when there is a proxy configured.
10:19 < GeKo> that might be an idea, yes.
10:19 < nickm> alternatively, you might come up with a fix that extends 5018 so that non-used clienttransportplugins don't prevent proxies from being set.
10:20 < nickm> The real fix is going to be something like #8402, but I make zero promises about merging that code is a remotely good idea at this point
10:20 -zwiebelbot:#tor-dev- [tor#8402: Tor should help its transport proxy use a proxy, if needed.]
10:20 < nickm> s/about/about whether/

comment:3 Changed 5 years ago by mttp

Cc: gk mikeperry added
Keywords: tbb-helpdesk-frequent added

comment:4 Changed 5 years ago by mcs

Cc: mcs added

I am fairly sure this is a duplicate of #11512.

We discussed this a week and a half ago during the Tor Browser IRC meeting and the consensus was that rather than add a lot of complexity to Tor Launcher, we would try to hold out for the real fix (#8402). But that means that people who need to use a proxy with TBB 3.6 will need to manually comment out the ClientTransportPlugin lines in Data/Tor/torrc-defaults (which is not good).

I should have reminded everyone about this issue when I saw the candidate builds for 3.6 appear :(

comment:5 Changed 5 years ago by mikeperry

Keywords: tbb-testcase added
Priority: normalmajor

comment:6 Changed 5 years ago by gk

Component: Tor LauncherTor bundles/installation
Resolution: fixed
Status: newclosed

This got fixed in 3.6.1 according to the change log.

Note: See TracTickets for help on using tickets.