Opened 6 years ago

Closed 6 years ago

#11672 closed defect (fixed)

Unwanted (invalid) redirection for OskiCat @ UC Berkeley

Reported by: cypherpunks Owned by: zyan
Priority: Low Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: httpse-ruleset-bug
Cc: kalvin.rubiksmaster@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On Firefox Nightly (I am using version 31 as of 1 May 2014) and HTTPS Everywhere 4.0 development 16, attempting to visit UC Berkeley's OskiCat (Library) Service results in HTTPS Everywhere rewriting the request to send me to an entirely invalid site. This was observed on a machine running Fedora 20, though should be platform-agnostic given the nature of the software involved.

Steps to reproduce:

  1. Open Firefox.
  1. Ensuring that HTTPS Everywhere is enabled, attempt to visit "oskicat.berkeley.edu." Prepending "https://" or "http://" should be irrelevant and optional, as HTTPS Everywhere will proceed to bug out on either case (in the absence of "http(s):," I believe Firefox adds it implicitly).
  1. Watch as Firefox immediately redirects you to the invalid, mispelled URL "https://oskicatp.berkeleye.edu/" or some variant thereof. For example, I receive that URL on either "http://" or entirely without prefix. If I start with typing "https://," I get "https://oskicatp.berkeleye.edu/somethingsomethingsometing" (not verbatim, it looks like it tries to take me to a login page, "oskicatp" notwithstanding).

Temporary Workaround:

  1. Open Firefox.
  1. Disable HTTPS Everywhere, either entirely or only on the UC Berkeley websites ("University of California (partial)."
  1. Visit OskiCat as normal (oskicat.berkeley.edu no longer redirects to oskicatp.berkeleye.edu).

Child Tickets

Change History (2)

comment:1 Changed 6 years ago by zyan

Thanks, what a typo. Fixed now.

comment:2 Changed 6 years ago by zyan

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.