Opened 6 years ago

Closed 4 years ago

#11740 closed defect (fixed)

Anti-spam plugins needed for Trac

Reported by: cypherpunks Owned by: erinn
Priority: High Milestone:
Component: Internal Services/Service - trac Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tracker needs some filters against automatic spammers else they will waste all beauty bug numbers.
http://trac.edgewall.org/wiki/SpamFilter or something.

Child Tickets

Change History (8)

comment:1 Changed 6 years ago by cypherpunks

Maybe filter anything containing an external URL by a recently created user, as a simple fix for now.

comment:2 Changed 6 years ago by nickm

Priority: normalmajor
Summary: Spam Filtering and/or Captcha needAnti-spam plugins needed for Trac

The spam-to-ham ratio on trac has gotten quite high this last week. It's time we looked into better anti-spam mechanisms. I believe the Tahoe-LAFS people had this problem recently too; it might be worthwhile asking them what they did and whether it worked. (Closed #11844 as a duplicate of this.)

comment:3 Changed 6 years ago by nickm

I asked Zooko; he says that the anti-spam plugin they are using has no way to writelist false poisitives. Zooko says that exarkun from the Twisted project has been interested in working on a better anti-spam plugin; that could be a lead worth following.

comment:4 Changed 6 years ago by erinn

Apparently we had no anti-spam plugin installed at all. I thought it was built into Trac 1.0, and we had options enabled in the trac.ini, but upon closer inspection I discovered that was not the case.

So, it's installed now, with more or less the default settings. Let's see if that improves anything. I'm also looking into enabling reCAPTCHA for registrations, and there is the option to also use Bayesian filtering which I'm looking into as well.

Please use this ticket to let me know if you see any improvement after today, and I'll start to fine tune the anti-spam setup.

comment:5 Changed 6 years ago by cypherpunks

Make your Skin Flexible And Toned Up

comment:6 Changed 6 years ago by nickm

We should remember to check the filter every day or two to see whether it's getting us any false positives.

comment:7 Changed 4 years ago by qbi

Component: TracService - trac

Move some tickets from trac to "Service - trac".

comment:8 Changed 4 years ago by qbi

Resolution: fixed
Status: newclosed

I'll close this ticket as the Anti-spam plugin is installed. However there are the tickets #13270 and #14680 which deal with other Anti-spam issues.

Note: See TracTickets for help on using tickets.