Opened 4 years ago

Closed 4 years ago

#11749 closed defect (invalid)

3.6 Breaks Android Emulator

Reported by: suomynona Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: tbb-usability
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Upgrade to 3.6 (apt-get update; apt-get dist-upgrade) breaks my previously working android emulator. Revert back to 3.5.4 snapshot and all is well. With 3.6, any use of emulator fails, no specific errors seen. (Did something change with openGL in 3.6 perhaps?)

Child Tickets

Change History (5)

comment:1 Changed 4 years ago by gk

Component: generalTor bundles/installation
Keywords: tbb-usability added; android adt 3.6 removed
Owner: set to erinn
Version: Tor: unspecified

Interesting. No, we did only change the things announced in the changelog (see: https://blog.torproject.org/blog/tor-browser-36-released) and there is nothing jumping out at me. So, could you give steps to reproduce your issue (the more detailed the better).

comment:2 Changed 4 years ago by cypherpunks

no specific errors seen

Emulators probably working but very very slow.

Something about fix for #9387

Disable JS JIT, type inference, asmjs, and ion.

Turn settings on and check if it will work.

comment:3 Changed 4 years ago by suomynona

The emulator shuts down, not that it's slow. Also I have a VBox snapshot set up, with 3.5.4 installed it runs, with 3.6.1 it shuts down (no other changes at all).

comment:4 Changed 4 years ago by suomynona

Steps to reproduce:

  1. Installed tor (my first time ever) when it was 3.5.4, about a week ago.
  2. Installed adt-bundle-linux-x86-20140321 from developer.android.com
  3. Run Android Debug Monitor (adt-bundle-linux-x86-20140321/sdk/tools/monitor)
  4. Window | Android Virtual Device Manager
  5. New... create Galaxy Nexus running android 4.4.2 (API 19)
  6. Select the new device (I called my GNex)
  7. Click start

voila...the device emulator runs

  1. Close the device, close the Virtual Device Manager, close the Android Debug Monitor
  1. Do upgrade of whonix to 3.6 (as described above)
  2. Now perform steps 3, 4, 6, & 7, watch as the emulator tries to start and then shuts itself down.
  3. Post a ticket on trac.torproject.org looking for help :-)

Let me know if that's not enough detail.

comment:5 Changed 4 years ago by suomynona

Resolution: invalid
Status: newclosed

...whonix problem, not tor. sorry

Note: See TracTickets for help on using tickets.