Opened 10 years ago

Last modified 7 years ago

#1175 closed defect (Fixed)

Current Tor bundle crashing on Mac OS X 10.4.11/Intel

Reported by: w Owned by: phobos
Priority: Low Milestone:
Component: Core Tor/Tor Version: 0.2.1.20
Severity: Keywords:
Cc: arma, phobos, Sebastian Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm downloading the regular recommended Tor bundle from the web site. When it crashes, I find this in the Vidalia log:

http://pastebin.com/m35b7f26d

[Automatically added by flyspray2trac: Operating System: OSX 10.4 Tiger]

Child Tickets

Change History (7)

comment:1 Changed 10 years ago by arma

OS Version: 10.4.11 (Build 8S2167)
Report Version: 4

Command: Vidalia
Path: /Applications/Vidalia.app/Contents/MacOS/Vidalia
Parent: WindowServer [73]

Version: 0.2.6 (0.2.6)

PID: 7961
Thread: Unknown

Link (dyld) error:

Library not loaded: /usr/lib/libiconv.2.dylib

Referenced from: /Applications/Vidalia.app/Contents/MacOS/Vidalia
Reason: Incompatible library version: Vidalia requires version 7.0.0 or later, but libiconv.2.dy

lib provides version 5.0.0

comment:2 Changed 10 years ago by nickm

Looks like a library version mismatch in Vidalia.

comment:3 Changed 10 years ago by phobos

The builds are done on leopard (os x 10.6), it appears the latest update changed the library. I'm working on it.

comment:4 Changed 10 years ago by arma

I believe this is all solved in the Vidalias that we include in our
recent bundles. Yes?

comment:5 Changed 10 years ago by phobos

Yes with vidalia 0.2.7.

comment:6 Changed 10 years ago by arma

flyspray2trac: bug closed.

comment:7 Changed 7 years ago by nickm

Component: Tor ClientTor
Note: See TracTickets for help on using tickets.