Opened 5 years ago

Closed 5 years ago

#11755 closed defect (fixed)

BBC (partial) rule prevents Flash loading video player on bbc.co.uk

Reported by: anon58684 Owned by: zyan
Priority: Very High Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: httpse-ruleset-bug
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The BBC (partial) rule prevents loading of the BBC's Flash video player (version 1.9.16.1444948-SMPFlash) on pages in the section http://www.bbc.co.uk/news/video_and_audio/video/

Versions in use:
Firefox 29.0 on Ubuntu 12.04.4 (all updates installed)
HTTPS Everywhere 3.5.1

To reproduce:

  1. Install HTTPS Everywhere, leave default settings.
  2. Browse to a video on BBC's website, good example: http://www.bbc.co.uk/news/uk-27275344

Expected Results:
BBC's Flash-based video player loads and I can click a button in the player to start playback of the video

Actual Results:
BBC's Flash-based video player doesn't load, it just shows a blank black square where the video should be

Workaround:
Disable the rule 'BBC (partial)' in HTTPS Everywhere preferences

Child Tickets

TicketStatusOwnerSummaryComponent
#12795closedzyanFlash player won't load in economist.comHTTPS Everywhere/EFF-HTTPS Everywhere

Change History (6)

comment:1 Changed 5 years ago by zyan

Priority: normalcritical

comment:2 Changed 5 years ago by zyan

Fixed in stable (3.5) for now by reverting the rule back to its state in 3.4.3. Leaving this open because the bug is still in master.

comment:3 Changed 5 years ago by zyan

Disabled for now on master.

comment:5 Changed 5 years ago by anon58684

How would I test this? Is there a nightly build or something of the add-on that I can install in Firefox?

comment:6 Changed 5 years ago by jsha

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.