Opened 5 years ago

Closed 5 years ago

#11822 closed defect (fixed)

Onionoo's contact parameter is broken for most relays

Reported by: karsten Owned by: karsten
Priority: High Milestone:
Component: Metrics/Onionoo Version:
Severity: Keywords:
Cc: Lunar Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Lunar reports that https://onionoo.torproject.org/details?type=relay&contact=adminsys@nos-oignons.net does not list any relays when it did before. It does work for other contacts, though. Possibly related to 51d883b. Needs more investigation.

Child Tickets

Change History (6)

comment:1 Changed 5 years ago by karsten

Possible fix in my task-11822 branch. We were overwriting a relay's contact information with null whenever that relay was contained in a consensus but did not publish a new server descriptor.

Will deploy in an hour when the current Onionoo run is done. Though we'll have to wait until tomorrow for the Nos Oignons relays to publish new descriptors. Then we'll see if the problem is fixed or not.

comment:2 Changed 5 years ago by lunar

At some point in the afternoon, marcuse1 and marcuse2 where back, but not ekumen. And now they are all gone.

comment:3 Changed 5 years ago by karsten

Looks like the fix didn't work as expected. I developed a better patch that I'm testing locally. If it works, I'll deploy it to yatei this afternoon.

comment:4 Changed 5 years ago by karsten

Deployed my task-11822-2 branch on yatei. Let's see whether that fixes the problem.

comment:5 Changed 5 years ago by lunar

They are all back now.

comment:6 Changed 5 years ago by karsten

Resolution: fixed
Status: newclosed

Yes, I think this issue is fixed. Pushed to master. Resolving. Thanks for reporting!

Note: See TracTickets for help on using tickets.