Opened 5 years ago

Closed 5 years ago

#11850 closed enhancement (duplicate)

Speed up the Tor v0.2.4.21 relay running on Windows XP

Reported by: hSF5gj7hv Owned by:
Priority: Medium Milestone:
Component: Metrics/Analysis Version:
Severity: Keywords: Tor v0.2.4.21 CircuitBuildTimeout LearnCircuitBuildTimeout CircuitIdleTimeout KeepalivePeriod NewCircuitPeriod NumEntryGuards RelayBandwidthBurst RelayBandwidthRate
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I started a new non-exit relay and I saw my "Average packaged cell fullness" is going down slow. Is there something wrong with it?

May 08 20:08:04.593 [Notice] Heartbeat: Tor's uptime is 1 day 6:00 hours, with 837 circuits open. I've sent 366.84 MB and received 352.46 MB.
May 08 20:08:04.593 [Notice] Average packaged cell fullness: 95.599%
May 08 20:08:04.593 [Notice] TLS write overhead: 8%
May 08 20:08:04.593 [Notice] Circuit handshake stats since last time: 5373/5373 TAP, 532/532 NTor.

May 09 01:46:21.796 [Notice] Your DNS provider has given "67.215.65.132" as an answer for 6 different invalid addresses. Apparently they are hijacking DNS failures. I'll try to correct for this by treating future occurrences of "67.215.65.132" as 'not found'.

May 09 02:08:04.593 [Notice] Heartbeat: Tor's uptime is 1 day 12:00 hours, with 325 circuits open. I've sent 878.75 MB and received 866.67 MB.
May 09 02:08:04.593 [Notice] Average packaged cell fullness: 83.555%
May 09 02:08:04.593 [Notice] TLS write overhead: 7%
May 09 02:08:04.593 [Notice] Circuit handshake stats since last time: 23811/23811 TAP, 1237/1237 NTor.

May 09 08:08:04.968 [Notice] Heartbeat: Tor's uptime is 1 day 18:00 hours, with 455 circuits open. I've sent 1.08 GB and received 1.06 GB.
May 09 08:08:04.968 [Notice] Average packaged cell fullness: 80.742%
May 09 08:08:04.968 [Notice] TLS write overhead: 7%
May 09 08:08:04.968 [Notice] Circuit handshake stats since last time: 12035/12035 TAP, 1082/1082 NTor.

May 09 14:08:04.968 [Notice] Heartbeat: Tor's uptime is 2 days 0:00 hours, with 962 circuits open. I've sent 1.29 GB and received 1.28 GB.
May 09 14:08:04.968 [Notice] Average packaged cell fullness: 73.114%
May 09 14:08:04.968 [Notice] TLS write overhead: 8%
May 09 14:08:04.968 [Notice] Circuit handshake stats since last time: 35059/35059 TAP, 620/620 NTor.

By the way, about DNS hijacking, my DNS provider is Google public DNS.

There is a way to use the tor.exe line command in Windows XP? I use the tor browser bundle v3.6 for Windows with vidalia-standalone-0.2.21-win32

Child Tickets

Change History (2)

comment:1 Changed 5 years ago by hSF5gj7hv

Keywords: Tor v0.2.4.21 CircuitBuildTimeout LearnCircuitBuildTimeout CircuitIdleTimeout KeepalivePeriod NewCircuitPeriod NumEntryGuards RelayBandwidthBurst RelayBandwidthRate added; Average packaged cell fullness removed
Summary: What means when the "Average packaged cell fullness" is going down slow?Speed up the Tor v0.2.4.21 relay running on Windows XP

I put in the vidalia's torcc:

CircuitBuildTimeout 5
LearnCircuitBuildTimeout 1
CircuitIdleTimeout 300
KeepalivePeriod 60
NewCircuitPeriod 5
NumEntryGuards 18

...

RelayBandwidthBurst "n" # "n" = my ISP bandwidth in Bytes/s permitted for download - ~5%
RelayBandwidthRate "m"  # "m" = my ISP bandwidth in Bytes/s permitted for upload - ~5%

comment:2 Changed 5 years ago by nickm

Resolution: duplicate
Status: newclosed

Seems to be a duplicate of #11885.

Note: See TracTickets for help on using tickets.