Opened 7 years ago

Closed 3 years ago

#11967 closed defect (duplicate)

TestingServerDownloadSchedule et al imply they're for TestingTorNetwork but actually they're sometimes not

Reported by: arma Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

  V(TestingServerDownloadSchedule, CSV_INTERVAL, "0, 0, 0, 60, 60, 120, "
                                 "300, 900, 2147483647"),

is the default value of the config option, and that's used in the real Tor network:

static const smartlist_t *
find_dl_schedule_and_len(download_status_t *dls, int server)
{
  switch (dls->schedule) {
    case DL_SCHED_GENERIC:
      if (server)
        return get_options()->TestingServerDownloadSchedule;
      else
        return get_options()->TestingClientDownloadSchedule;
[...]

But if you set TestingTorNetwork, then its value gets replaced by

  V(TestingServerDownloadSchedule, CSV_INTERVAL, "0, 0, 0, 5, 10, 15, "
                                 "20, 30, 60"),

and the code in directory.c stays the same.

Am I the only one who thinks that calling it a TestingFooBarSchedule when it's not for Testing is weird?

Child Tickets

Change History (6)

comment:1 Changed 7 years ago by nickm

From a user's POV, it *is* for testing; you can only change it when TestingTorNetwork is set --at least, that's what the CHECK_DEFAULT() in options_validate is supposed to do. I guess the issue here is that it's still called TestingServerDownloadSchedule internally to the Tor code?

comment:2 Changed 7 years ago by arma

Yes, I'm talking about how it looks internally in the Tor code.

comment:3 Changed 4 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:4 Changed 4 years ago by nickm

Keywords: tor-03-unspecified-201612 added
Milestone: Tor: 0.3.???Tor: unspecified

Finally admitting that 0.3.??? was a euphemism for Tor: unspecified all along.

comment:5 Changed 4 years ago by nickm

Keywords: tor-03-unspecified-201612 removed

Remove an old triaging keyword.

comment:6 Changed 3 years ago by nickm

Resolution: duplicate
Severity: Normal
Status: newclosed

Closed as duplicate of #8954.

Note: See TracTickets for help on using tickets.