Opened 5 years ago

Closed 15 months ago

#12000 closed defect (wontfix)

Detect when a probe is using the wrong test helpers

Reported by: cypherpunks Owned by: hellais
Priority: Medium Milestone:
Component: Archived/Ooni Version:
Severity: Normal Keywords: archived-closed-2018-07-04
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This issue was automatically migrated from github issue https://github.com/TheTorProject/ooni-probe/issues/158.

As @stephen-soltesz pointed in out in a ticket:

Also, I recall a discussion in Berlin about validation of uploaded reports; specifically, at the time of report upload, it is necessary to determine that the "expected test-helper" and the "used test-helper" are the same type. This helps eliminate false-positives due to report errors caused by mismatches between the test-helper expected and used. This validation requires that the report is uploaded to the collector co-located with the test helper. Can testdecks be created to support the above?

The hard part of doing this is making the collector speak to the test helpers. In other words to detect that the expected test helper is not the one used, we have to has the test helper that the user is supposed to be using if they have seen those requests from our user.

Child Tickets

Change History (2)

comment:1 Changed 22 months ago by teor

Severity: Normal

Set all open tickets without a severity to "Normal"

comment:2 Changed 15 months ago by teor

Keywords: archived-closed-2018-07-04 added
Resolution: wontfix
Status: newclosed

Close all tickets in archived components

Note: See TracTickets for help on using tickets.