Opened 5 years ago

Closed 5 years ago

#12039 closed defect (fixed)

HTTPS Everywhere Preferences only lists a few rulesets

Reported by: cypherpunks Owned by: zyan
Priority: High Milestone: HTTPS-E 4 stable
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: fanatic.64_emu64@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On a clean installation of Firefox 29.0.1 and HTTPS Everywhere 4.0 Development 16, when opening the "HTTPS Everywhere Preferences" window, only 1 or 2 rulesets are listed. After browsing for a while, the list grows, but only with a few dozen rulesets. Also upon restarting the browser the list is nearly empty again, and after opening any page some random rulesets from the previous session appear again.

Regardless of intention, this seems like erratic behavior. Plus it's annoying to not be able to manage all rulesets from a single place. I personally like to enable the CACert rules and install the root certificate...

This happens with the Development 15 version too. Development 14 and earlier do not have this issue.

A screenshot showing the issue is attached.

Child Tickets

Attachments (1)

rulesetlist.png (248.1 KB) - added by cypherpunks 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by cypherpunks

Attachment: rulesetlist.png added

comment:1 Changed 5 years ago by cypherpunks

Summary: HTTPS Everywhere Preferences only lists rulesets for sites that have already been visited.HTTPS Everywhere Preferences only lists a few rulesets

comment:2 Changed 5 years ago by zyan

Resolution: fixed
Status: newclosed

Fixed now on master.

Note: See TracTickets for help on using tickets.