Opened 6 years ago

Closed 6 years ago

#12068 closed defect (duplicate)

Assertion smartlist_get(rl->old_routers, idx) == sd failed

Reported by: theking2 Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.4.21
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Around midnight tor failed:

May 20 14:43:52 janus tor[338]: May 20 14:43:52.995 [notice] Tor v0.2.4.21 (git-505962724c05445f) running on Linux with Libevent 2.0.21-stable and OpenSSL
May 20 14:43:52 janus tor[338]: May 20 14:43:52.995 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/do
May 20 14:43:53 janus tor[338]: May 20 14:43:53.010 [notice] Read configuration file "/etc/tor/torrc".
May 20 14:43:53 janus tor[338]: May 20 14:43:53.085 [notice] Opening Socks listener on 127.0.0.1:9050
May 20 14:43:53 janus tor[338]: May 20 14:43:53.085 [notice] Opening DNS listener on 127.0.0.1:9053
May 20 14:43:53 janus tor[338]: May 20 14:43:53.093 [notice] Opening OR listener on 0.0.0.0:9001
May 20 14:43:53 janus tor[338]: May 20 14:43:53.093 [notice] Opening Directory listener on 0.0.0.0:9030
May 21 00:05:19 janus tor[338]: src/or/routerlist.c:3167 routerlist_remove_old: Assertion smartlist_get(rl->old_routers, idx) == sd failed; aborting.

Child Tickets

Change History (3)

comment:1 Changed 6 years ago by cypherpunks

Happened for previous versions as reported in #6767. If this is not a memory corruption then probably bug is rare but real.

comment:2 Changed 6 years ago by nickm

Closing as duplicate of #6767 . It would be good to have more information here. Are you able to copy your torrc to that ticket?

If this is not a memory corruption [...]

This is probably not memory corruption.

comment:3 Changed 6 years ago by nickm

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.