Opened 5 years ago

Closed 5 years ago

#12090 closed defect (fixed)

BridgeDB replies with an empty email.

Reported by: mttp Owned by: isis
Priority: Immediate Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Keywords: bridgedb-email, bridgedb-0.2.3
Cc: sysrqb, isis Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Users are reporting that when they request bridges from bridges(a)torproject.org or bridges(a)bridges.torproject.org from a gmail account they receive in reply only an empty email. It appears this happens even when the request is made correctly, (i.e. with a 'get bridges' or 'transport=obfs3' in the body).

It's unclear for me right now if these are accounts that have ever received bridges over email before or not.

Child Tickets

Change History (3)

comment:1 Changed 5 years ago by isis

Cc: isis added
Keywords: bridgedb-email added
Priority: normalblocker

I can confirm reproducibility for this bug, since I noticed last it last night.

I haven't been able to find the source of the problem because this bug is not reproducible either with the CI server or locally on my laptop. This probably means it's a Python-2.7.3 specific bug, meaning that to debug it, one would need to create a Debian Wheezy VM, install BridgeDB on it, and then try to figure out why that specific version of Python is messing things up.

comment:2 in reply to:  description Changed 5 years ago by Meng

Replying to mttp:

Users are reporting that when they request bridges from bridges(a)torproject.org or bridges(a)bridges.torproject.org from a gmail account they receive in reply only an empty email. It appears this happens even when the request is made correctly, (i.e. with a 'get bridges' or 'transport=obfs3' in the body).

I can't even get a reply.

It's unclear for me right now if these are accounts that have ever received bridges over email before or not.

comment:3 Changed 5 years ago by isis

Keywords: bridgedb-0.2.3 added
Resolution: fixed
Status: newclosed

These bugs were hotfixed by sysrqb on ponticum, and I extracted the patches and committed them in the fix/12627-hotfixes branch. They still don't show up on any machine but ponticum, so I'm still assuming that there were some interface changes between the crazy old version of Python on the server and the ones on other machines.

This has been merged for version 0.2.3, and the patches are already running on the server.

This bug should be fixed. Feel free to reopen if it continues.

Note: See TracTickets for help on using tickets.