Opened 3 years ago

Closed 3 years ago

Last modified 10 months ago

#12092 closed defect (duplicate)

MyFamily argument doesn't work with nicknames of relays with Unnamed flag

Reported by: s7r Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.4.21
Severity: Keywords: named, unnamd, flags, family declare problem
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I report the following discovered "bug" if you could call it that:

I have 5 relays. All running Tor 0.2.4.21 on FreeBSD or Debian.
2 relays have the Named flag
3 relays had the Named flag, but had to change the keys after heartbleed and lost the named flag, got the Unnamed flag.

I have properly declared the family in all relays torrc, via nickname, not fingerprint (ouch but I have an excuse why I didn't use fingerprints so I am opening another ticket for that too, it's manual related).

The atlas shows the fingerprints for the 2 relays with Named flag, as properly declared family. The other 3 relays, with Unnamed flag appear only with nicknames in Atlas, as NOT a properly declared family. I have browsed atlas for almost 3 days and everywhere the same problem, relays with unnamed flag specified by their nickname do not appear as valid family members, doesn't matter if they are properly declared in config files of the relays.

So, either remove Named / Unnamed flags or don't allow to specify family members via nickname in torrc.

All the arguments in torrc which require fingerprints, accept fingerprints as they are, ony MyFamily argument requires $ in front of the fingerprint. This is confusing.

Child Tickets

Change History (5)

comment:1 Changed 3 years ago by s7r

The manual should be updated, at MyFamily, to specify that IF you use fingerprints they need to be preceeded by "$", unlike every other option which requries fingerprints.

Or better -> make Tor to accept fingerprints at MyFamily without being preceeded by "$", see ticket #12093

Last edited 3 years ago by s7r (previous) (diff)

comment:2 Changed 3 years ago by teor

We've now turned the Named flag off on directory authorities. This means that all nicknames will/have become unusable in MyFamily.

This may require an update to the FAQ https://www.torproject.org/docs/faq#MultipleRelays
as well as the update noted in #4341

comment:3 Changed 3 years ago by Sebastian

Resolution: duplicate
Status: newclosed

I fixed the faq. I'm marking the rest as a duplicate of #12898

comment:4 Changed 11 months ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:5 Changed 10 months ago by nickm

Milestone: Tor: 0.3.???

Milestone deleted

Note: See TracTickets for help on using tickets.