Opened 4 years ago

Closed 4 years ago

Last modified 15 months ago

#12119 closed defect (duplicate)

Tor Browser hangs on startup

Reported by: cypherpunks Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Blocker Keywords: tbb-usability
Cc: mcs Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On Linux, both Fedora 19 and Mint 13 and both 32 and 64 bit, the firefox browser (Tor Browser 3.6.1) sometimes hangs and never starts. strace -p shows that the firefox hang is due to FUTEX_WAIT_PRIVATE. The tor daemon component always starts and works correctly which was verified with torsocks.

Child Tickets

Change History (5)

comment:1 Changed 4 years ago by gk

Keywords: tbb-usability added; browser futex linux removed
Version: Tor: unspecified

What does the log output given on the command line say?

comment:2 Changed 4 years ago by mcs

Cc: mcs added

comment:3 in reply to:  1 Changed 4 years ago by cypherpunks

Replying to gk:

What does the log output given on the command line say?

Please see below for a list of the commands and outputs. This still occurs with TBB 3.6.2. Firefox always comes up in debug mode. Thanks for your interest.

$ ./start-tor-browser

Launching Tor Browser Bundle for Linux in ./tor-browser_en-US

(process:1534): GLib-CRITICAL : g_slice_set_config: assertion `sys_page_size == 0' failed
Jun 11 22:56:32.833 [notice] Tor v0.2.4.22 (git-345e00dc68a052fe) running on Linux with Libevent 2.0.21-stable and OpenSSL 1.0.1h.
Jun 11 22:56:32.834 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://www.torproject.org/download/download#warning
Jun 11 22:56:32.835 [notice] Read configuration file "./tor-browser_en-US/Data/Tor/torrc-defaults".
Jun 11 22:56:32.835 [notice] Read configuration file "./tor-browser_en-US/Data/Tor/torrc".
Jun 11 22:56:32.854 [notice] Opening Socks listener on 127.0.0.1:9150
Jun 11 22:56:32.855 [notice] Opening Control listener on 127.0.0.1:9151
Jun 11 22:56:32.000 [notice] Pluggable transport proxy (fte exec ./Tor/PluggableTransports/fteproxy.bin --managed) does not provide any needed transports and will not be launched.
Jun 11 22:56:32.000 [notice] Pluggable transport proxy (obfs2,obfs3 exec ./Tor/PluggableTransports/obfsproxy.bin managed) does not provide any needed transports and will not be launched.
Jun 11 22:56:32.000 [notice] Pluggable transport proxy (flashproxy exec ./Tor/PluggableTransports/flashproxy-client --register :0 :9000) does not provide any needed transports and will not be launched.
Jun 11 22:56:32.000 [notice] Parsing GEOIP IPv4 file ./tor-browser_en-US/Data/Tor/geoip.
Jun 11 22:56:33.000 [notice] Parsing GEOIP IPv6 file ./tor-browser_en-US/Data/Tor/geoip6.
Jun 11 22:56:35.000 [notice] Bootstrapped 5%: Connecting to directory server.
Jun 11 22:56:35.000 [notice] We now have enough directory information to build circuits.
Jun 11 22:56:35.000 [notice] Bootstrapped 80%: Connecting to the Tor network.
Jun 11 22:56:35.000 [notice] New control connection opened.
Jun 11 22:56:35.000 [notice] Pluggable transport proxy (fte exec ./Tor/PluggableTransports/fteproxy.bin --managed) does not provide any needed transports and will not be launched.
Jun 11 22:56:35.000 [notice] Pluggable transport proxy (obfs2,obfs3 exec ./Tor/PluggableTransports/obfsproxy.bin managed) does not provide any needed transports and will not be launched.
Jun 11 22:56:35.000 [notice] Pluggable transport proxy (flashproxy exec ./Tor/PluggableTransports/flashproxy-client --register :0 :9000) does not provide any needed transports and will not be launched.
Jun 11 22:56:35.000 [notice] Bootstrapped 85%: Finishing handshake with first hop.
Jun 11 22:56:35.000 [notice] New control connection opened.
Jun 11 22:56:35.000 [notice] Bootstrapped 90%: Establishing a Tor circuit.
Jun 11 22:56:36.000 [notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Jun 11 22:56:36.000 [notice] Bootstrapped 100%: Done.

$ ps ax | grep firefox

1534 pts/0 Sl+ 0:06 ./Browser/firefox -no-remote -profile Data/Browser/profile.default

$ strace -p 1534
Process 1534 attached
futex(0x9fe5af48, FUTEX_WAIT_PRIVATE, 1, NULL

comment:4 Changed 4 years ago by gk

Resolution: duplicate
Status: newclosed

This is very likely a duplicate of #9531.

comment:5 Changed 15 months ago by Stanley763

Severity: Blocker

Thanks for this working solution about
Best Automatic Litter Box

Note: See TracTickets for help on using tickets.